Ticket #6793 (closed Bug: wontfix)

Opened 4 years ago

Last modified 4 years ago

Copy Paste of List not functioning properly

Reported by: naresh.sivaraman Owned by:
Priority: Normal Milestone:
Component: General Version: 3.4.2
Keywords: Oracle IE Cc:

Description

Found in IE7.

  1. create a numeric list with 3 items (111, 222, 333), then select

these 3 lines and copy it to clipboard. (Please note that selecting just after "333" in last line, DO NOT include blank characters at the end of last line.) (Attaching a picture to give a better idea)

  1. Paste it using the 'Paste' icon and not Ctrl+V . When using Ctrl+V, it works fine.
  1. The list copied comes as bullets and the formatting is different.

Looks like the <ol> is not being copied and only the <li>'s are being copied in this case.

Attachments

CopyPasteList.JPG (24.8 KB) - added by naresh.sivaraman 4 years ago.

Change History

Changed 4 years ago by naresh.sivaraman

comment:1 Changed 4 years ago by wwalc

  • Keywords Oracle added

comment:2 Changed 4 years ago by krst

  • Status changed from new to closed
  • Resolution set to worksforme

WFM 3.4.2 IE 7

comment:3 Changed 4 years ago by krst

  • Status changed from closed to reopened
  • Resolution worksforme deleted

comment:4 Changed 4 years ago by krst

  • Keywords IE7 added
  • Status changed from reopened to pending

I cannot reproduce this issue

comment:5 Changed 4 years ago by krst

  • Under which OS it happens?
  • Does this bug occur also in CKEditor v3.4.3 or v3.5?
  • Does CKEditor have default settings or some custom ones? If custom, could You tell us what has been changed?

comment:6 Changed 4 years ago by naresh.sivaraman

Details you have asked for:

(1) I am using Windows XP only for testing.(IE7) (2) Was able to reproduce the same in CKEDITOR 3.5 too. (3) Have been testing this in ckeditor.com/demo only and so have not used any custom settings.

I do feel this is a very nitpicky issue. But its a request from our customer. I think you are not able to reproduce it because of the way you are selecting when doing the copy-paste. Please see the picture i have attached for that. It would help. The selection has to be done just after "333" in last line, Please DO NOT include blank characters at the end of last line.

comment:7 Changed 4 years ago by garry.yao

  • Keywords IE added; IE7 removed
  • Status changed from pending to confirmed

Confirmed in IE7 browser mode (WFM in IE7 document mode), when a list is partially selected:

  1. Browser sent only list items from clipboard with paste command;
  2. Browser sent full list with "ctrl-v";

As with other IE7 pasting bug we've seen caused by the bug of browser's paste command, we could provide no fix here.

comment:8 Changed 4 years ago by garry.yao

  • Status changed from confirmed to closed
  • Resolution set to wontfix
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy