Ticket #6912 (closed Bug: fixed)

Opened 4 years ago

Last modified 3 years ago

too much recursion

Reported by: chris_mac Owned by:
Priority: Normal Milestone:
Component: General Version: 3.4.2
Keywords: Cc: chris.macdonald@…

Description

I'm getting this message in ff 3.6.13, safari 5.0.2 (5533.18.5), ie 8, both mac 10.5.8, 10.6.3 and windows 7 (for the ie one).

too much recursion [Break On This Error] return;}if(E=='br'){v.push(H);return;}...n=='br'),q=!!o.$empty[l];r.isEmpty=q; ckeditor.js (line 27)

I get this if I click the source button of the editor and then the option to select it again is not present. My editor can be seen here

http://174.120.151.156/~crazychr/editor.php

I'm not sure of the version number of it. This is occurring when pasting text in from open office/word 1 out of maybe 15 times. Do you want a word file that this occurs with or a copy of the source code Dreamweaver generates when I paste it there? I can't get the source code ck is generating.

Attachments

dreamweaveroutput.html (23.2 KB) - added by chris_mac 4 years ago.
Dreamweaver output of OpenOffice docx

Change History

comment:1 Changed 4 years ago by chris_mac

  • Cc chris.macdonald@… added

comment:2 Changed 4 years ago by garry.yao

  • Status changed from new to pending
  • Keywords too much recursion removed

This's generally a parser hang problem caused by invalid HTML structure, the original pasted content is critical for reproducing.

comment:3 Changed 4 years ago by chris_mac

The HTML dreamweaver outputs or the DOC file?

comment:4 follow-up: ↓ 5 Changed 4 years ago by alfonsoml

  • Version set to 3.4.2

If HTML from dreamweaver can cause the problem that would be better, but it might be a problem in the way that Open Office generates the HTML and in that case we would need that document as well as the version of Open Office that you are using.

comment:5 in reply to: ↑ 4 Changed 4 years ago by chris_mac

Okay, I've got the dreamweaver output. To get the dreamweaver output I copied from OpenOffice 3.2.0 Build 9483, and pasted it into the design panel. I copied that code from the code view and pasted it in the source view of the CKEditor. This is a link of the process and where it fails in both. If you need the doc file as well please let me know. Thanks.

http://www.screencast-o-matic.com/watch/c6lObcXAA

I don't see an upload option here but maybe it's on the next page?

Changed 4 years ago by chris_mac

Dreamweaver output of OpenOffice docx

comment:6 Changed 4 years ago by chris_mac

Is there anything else needed for you to be able to reproduce this? Should I try to simplify that html output, or do you need the doc(x)?

comment:7 Changed 4 years ago by alfonsoml

  • Status changed from pending to confirmed

Simplified test case:

<dl>
     <dl>
          <dl>
               <dd>
          </dl>
          <dd>
     </dl>
</dl>
<dl>
     <dl>
          <dd>
     </dl>
</dl>

As the source code has been loaded (even if it's nesting elements incorrectly), I think that it should be able to return something and not crash in a recursion loop when turning the content into HTML.

The strange thing is that <li> and <ul> are inserted into the content if that code is further simplified, and that bogus fixing might be the cause of the problems.

comment:8 Changed 4 years ago by chris_mac

Any status update on this bug?

comment:9 Changed 3 years ago by wwalc

  • Status changed from confirmed to pending

Works for me in trunk, anyone can confirm it?

comment:10 Changed 3 years ago by j.swiderski

  • Status changed from pending to closed
  • Resolution set to fixed

It seems that it was fixed in CKE 3.5.3

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy