Ticket #6985 (closed Bug: fixed)

Opened 4 years ago

Last modified 14 months ago

Whitespace lost on paste in FF

Reported by: steve_wood Owned by:
Priority: Normal Milestone:
Component: Core : Pasting Version: 3.0
Keywords: Firefox Opera IBM Cc: lynne_kues

Description

When you copy and paste some text, leading whitespace is removed on FF only. This is easy to reproduce just copy some text with a space as the first character, when you paste it the space is not preserved. Seems to work on IE and WebKit so not sure whether this is something that can be controlled or not. This can be replicated on the demo http://ckeditor.com/demo

Change History

comment:1 Changed 4 years ago by krst

  • Status changed from new to confirmed
  • Keywords Firefox added
  • Version changed from 3.5 to 3.0
  • Component changed from General to Core : Pasting

comment:2 follow-up: ↓ 3 Changed 4 years ago by satya

This one is fixed.Please close this defect.

comment:3 in reply to: ↑ 2 ; follow-up: ↓ 4 Changed 4 years ago by steve_wood

Replying to satya:

This one is fixed.Please close this defect.

I still see it on FF 3.6 on the demo which is using CKEditor 3.5.3 (revision 6655)

comment:4 in reply to: ↑ 3 Changed 4 years ago by satya

Replying to steve_wood:

Replying to satya:

This one is fixed.Please close this defect.

I still see it on FF 3.6 on the demo which is using CKEditor 3.5.3 (revision 6655)

@ steve_wood i am using 3.5.3 and FF 3.6.16 and i could not reproduce this issue.

comment:5 Changed 4 years ago by satya

  • Keywords IBM removed

comment:6 Changed 4 years ago by steve_wood

@satya I am also using FF 3.6.16 and it happens on the demo at http://ckeditor.com/demo

The selection must start with a space e.g. select " version most" from the 2nd paragraph, place the cursor at at the end of the 2nd paragraph hit ctrl-v and notice that the leading space is lost. So what you end up with is "...grandmother.version most."

comment:7 Changed 3 years ago by satya

  • Keywords IBM added

comment:8 Changed 3 years ago by j.swiderski

  • Keywords Opera added

This issue has also been reproducible in Opera.

comment:9 Changed 3 years ago by j.swiderski

#8735 was marked as dulicate.

comment:10 Changed 14 months ago by Reinmar

  • Status changed from confirmed to closed
  • Resolution set to fixed

Fixed in CKEditor 4.0.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy