Ticket #7151 (closed Bug: duplicate)

Opened 4 years ago

Last modified 4 years ago

StylesCombo doesn't honor the bodyId configuration option

Reported by: alexk Owned by:
Priority: Normal Milestone:
Component: General Version: 3.5.1
Keywords: Cc:

Description

The CKEDITOR.config.bodyId isn't applyed to the StylesCombo dialog. For that some styles are not applyed in the dropdown-selectors.

Steps to reproduce: 1) create a stylesheet that contains a style like: #somebodyid h1.red {

color: red;

}

2) in the configuration specify: bodyId: 'somebodyid', contentsCss: 'http://link.to/your/stylesheet'

3) add a stylesset to the editor: CKEDITOR.stylesSet.add( 'my_style', [ {

name : 'h1.red', element : 'h1', attributes : { 'class' : 'red'} } } ]);

With this setup a element like <h1 class="red">hello</h1> will be rendered correctly in the editing area. But if you open then Sylescombo dropdown, the "preview" of the style won't be red as it should be.

Change History

comment:1 Changed 4 years ago by Saare

  • Status changed from new to closed
  • Resolution set to duplicate

Closing this one as a dup of #7452, because it contains some more info.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy