Opened 5 years ago

Closed 5 years ago

#7347 closed Bug (fixed)

In page key handlers are catching ENTER key on toolbar buttons

Reported by: Rajasimhan Owned by: fredck
Priority: Normal Milestone: CKEditor 3.5.4
Component: UI : Dialogs Version: 3.2
Keywords: Oracle Cc: senthil.kumaran@…, rajasimhan.baskar@…

Description

Ticket #4269 addressed the following issue - "Esc" and "Enter" keystrokes are not handled when a dialogue box is opened which causes the form post automatically.

But this issue is now re occurring in 3.5.2. Please check this and provide a fix.

Because of this issue whenever any plugins with a modal pop up window like Image Plugin, Links Plugin, Find & Replace are clicked either the window disappears immediately after it opens or the browser hangs as the JS goes in an infinite loop.

Attachments (4)

postissue.2.html (1.5 KB) - added by Rajasimhan 5 years ago.
postissue.html (1.5 KB) - added by Rajasimhan 5 years ago.
File to replicate the form post issue
Replication Files.zip (1.6 KB) - added by Rajasimhan 5 years ago.
Replication Files
7347.patch (892 bytes) - added by fredck 5 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 5 years ago by j.swiderski

  • Status changed from new to pending

We were unable to reproduce the problem. Everything seems to be fine. Esc key behaves like Cancel button and Enter behaves like OK button. We couldn't also get any infinite loops or browser crashes.

Could you provide us with more details, like what OS are you using, which browsers does the issue concern? We would also be grateful for a detailed step by step scenario on how to reproduce the bug.

comment:2 follow-up: Changed 5 years ago by Rajasimhan

  • Cc rajasimhan.baskar@… added

Hi,

Kindly bear with the delay. Please copy the attached file 'postissue.html' into the ckeditor\_samples folder.

  1. Open the postissue.html. Editor will be rendered. Click inside the text area and press Alt-F10.
  2. Tab till you reach 'Find and Replace' and press the enter key.
  3. Form post will happen ( you would be taken to the 'sample_posteddata.php').

Browsers: This happens in FireFox and IE. OS: Windows. CKEditor Version: 3.5.2

comment:3 in reply to: ↑ 2 Changed 5 years ago by Rajasimhan

Replying to Rajasimhan:

Hi,

Kindly bear with the delay. Please copy the attached file 'postissue.html' into the ckeditor\_samples folder.

  1. Open the postissue.html. Editor will be rendered. Click inside the text area and press Alt-F10.
  2. Tab till you reach 'Find and Replace' and press the enter key.
  3. Form post will happen ( you would be taken to the 'sample_posteddata.php').

Browsers: This happens in FireFox and IE. OS: Windows. CKEditor Version: 3.5.2

https://dev.ckeditor.com/attachment/ticket/7347/postissue.html

Changed 5 years ago by Rajasimhan

Changed 5 years ago by Rajasimhan

File to replicate the form post issue

comment:4 Changed 5 years ago by j.swiderski

  • Status changed from pending to confirmed
  • Version changed from 3.5.2 to 3.2

Has happened from CKEditor version 3.2

comment:5 Changed 5 years ago by fredck

  • Summary changed from Fix for the Ticket #4269 has regressed. to In page key handlers are catching ENTER key on toolbar buttons

Note that this issue is not related to #4269, which instead was addressing these keys on dialogs. This new ticket is talking about ENTER on the toolbar.

Please note that this issue is more related to an issue with your code than with the editor. The fact is that ENTER is happening on the page and your code is catching all instead of just the things you need to catch. We had already discussed this when talked about #4269 so it's not worth reopening this talk, but considering that this is an issue with your code and not CKEditor, it has lower priority.

Changed 5 years ago by Rajasimhan

Replication Files

comment:6 Changed 5 years ago by fredck

This happens since [6303].

The dialog cover is created on keydown. At that point, the focus is set to it. So now the keyup event is caught by the dialog cover, not by the editor container.

This has nothing to do with CKEditor API features though.

Changed 5 years ago by fredck

comment:7 Changed 5 years ago by fredck

  • Milestone set to CKEditor 3.5.4
  • Owner set to fredck
  • Status changed from confirmed to review

It's enough to prevent key events on the cover at this point.

comment:8 Changed 5 years ago by fredck

  • Component changed from General to UI : Dialogs

comment:9 Changed 5 years ago by Saare

  • Status changed from review to review_passed

comment:10 Changed 5 years ago by fredck

  • Resolution set to fixed
  • Status changed from review_passed to closed

Fixed with [6676].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy