Opened 9 years ago

Closed 8 years ago

#738 closed Bug (fixed)

Cannot change the button type after creating it

Reported by: aaronvg@… Owned by: martinkou
Priority: Normal Milestone: FCKeditor 2.6
Component: General Version: FCKeditor 2.5.1
Keywords: Confirmed IE Review- Cc:

Description

Once inserted, one cannot change the button type of a button in a form anymore.

Steps:

- Insert form
- Insert button (type = button)
- Open contextmenu of button
- Type field is disabled.

Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1501651&group_id=75348&atid=543653

Attachments (1)

738.patch (1.9 KB) - added by martinkou 8 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 9 years ago by martinkou

  • Reporter changed from martinkou to aaronvg@…

comment:2 Changed 8 years ago by w.olchawa

  • Keywords Confirmed IE IE7 added
  • Summary changed from Cannot change the button type of a button to Cannot change the button type after creating it
  • Version set to FCKeditor 2.5.1

Confirmed on IE and IE7. In FF the problem is bigger because you can't access the button properties. See #703.

comment:3 Changed 8 years ago by w.olchawa

  • Keywords IE7 removed

comment:4 Changed 8 years ago by martinkou

  • Owner set to martinkou
  • Status changed from new to assigned

comment:5 Changed 8 years ago by martinkou

Targeting to 2.6 since it is related to dialogs.

Changed 8 years ago by martinkou

comment:6 Changed 8 years ago by martinkou

  • Keywords Review? added
  • Milestone set to FCKeditor 2.6

comment:7 Changed 8 years ago by alfonsoml

  • Keywords Review- added; SF Review? removed

That code would lose any other property that isn't handled by this dialog (like class, style or any event handler). It might not be common, but it is a possibility. So I Review- because that's data loss.

In #676 I added the code to handle also this issue, but there are some ideas (like not creating a new element if the special properties haven't changed) in this patch that I must apply.

comment:8 Changed 8 years ago by alfonsoml

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in #676

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy