Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#7619 closed Bug (fixed)

CKEditor dialogs are displayed behind ActiveX controls in IE

Reported by: tmonahan Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.6.2
Component: UI : Dialogs Version: 3.0
Keywords: IBM Cc: damo, satya, jamescun

Description

When an ActiveX control is included in a HTML page that also includes CKEditor, CKEditor dialogs are displayed behind the ActiveX control in IE. For example, copy the attached test case into the _samples directory. Open it in IE, and open the 'Insert Image' dialog. The dialog is displayed behing the activeX control.

This occurs in IE7 and IE8. In IE6, there appears to be a different issue where the activeX control does not display when the dialog is open. There seems to be some IE6 specific code in the showCover and hideCover functions in dialog\plugin.js which adds an iframe as a child of the dialog background cover which could account for this difference.

Attachments (3)

activeX_testcase.html (1.1 KB) - added by tmonahan 5 years ago.
7619.patch (1.9 KB) - added by garry.yao 5 years ago.
7619error.JPG (123.6 KB) - added by satya 5 years ago.

Download all attachments as: .zip

Change History (15)

Changed 5 years ago by tmonahan

comment:1 Changed 5 years ago by j.swiderski

  • Status changed from new to confirmed
  • Version changed from 3.5.3 to 3.0

Happens in all browsers.

In FF4 only the corners are hidden.

Opera is the only browser where dialog is not covered but the youtube movie is hidden instead (which is very interesting by the way:)). I'm not sure if this is the correct behavior.

comment:2 Changed 5 years ago by garry.yao

  • Resolution set to invalid
  • Status changed from confirmed to closed

This should be fixed by the app instead of editor, check transparent flash option.

comment:3 Changed 5 years ago by tmonahan

This is not only an issue with flash content - it happens for all activeX controls. Therefore the proposed solution is not valid. Can you please reopen this ticket to investigate further?

comment:4 Changed 5 years ago by fredck

  • Resolution invalid deleted
  • Status changed from closed to reopened

I'm not sure we're able to workaround this problem, but this is certainly a valid issue.

comment:5 in reply to: ↑ description ; follow-up: Changed 5 years ago by fredck

  • Component changed from General to UI : Dialogs
  • Status changed from reopened to confirmed

Replying to tmonahan:

There seems to be some IE6 specific code in the showCover and hideCover functions in dialog\plugin.js which adds an iframe as a child of the dialog background cover which could account for this difference.

In fact, this may be a solution for it.

comment:6 in reply to: ↑ 5 Changed 5 years ago by damo

Replying to fredck:

Replying to tmonahan:

There seems to be some IE6 specific code in the showCover and hideCover functions in dialog\plugin.js which adds an iframe as a child of the dialog background cover which could account for this difference.

In fact, this may be a solution for it.

Any update on this one?

comment:7 Changed 5 years ago by garry.yao

Ticket Test: run OR view source.

Last edited 5 years ago by garry.yao (previous) (diff)

Changed 5 years ago by garry.yao

comment:8 Changed 5 years ago by garry.yao

  • Owner set to garry.yao
  • Status changed from confirmed to review

comment:9 Changed 5 years ago by fredck

  • Milestone set to CKEditor 3.6.2
  • Status changed from review to review_passed

comment:10 follow-up: Changed 5 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from review_passed to closed

Fixed with [7201].

comment:11 in reply to: ↑ 10 ; follow-up: Changed 5 years ago by satya

Replying to garry.yao:

Fixed with [7201].

@garry.yao This is not properly fixed. Download the attached test case,modify the src to point to nightly build. with out keeping focus in editor, click on link or image icon it strips all the CSS and you will get a javascript error.

Please re oprn this ticket. I have attached a screenshot of the error.

Changed 5 years ago by satya

comment:12 in reply to: ↑ 11 Changed 5 years ago by fredck

Replying to satya:

@garry.yao This is not properly fixed. Download the attached test case,modify the src to point to nightly build. with out keeping focus in editor, click on link or image icon it strips all the CSS and you will get a javascript error.

Please re oprn this ticket. I have attached a screenshot of the error.

I'm not able to reproduce this problem. In any case, such issue is not related to this ticket and deserves a dedicated one.

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy