Ticket #7945 (closed Bug: fixed)

Opened 3 years ago

Last modified 19 months ago

Block insertion in table caption

Reported by: garry.yao Owned by:
Priority: Normal Milestone:
Component: Core : Pasting Version: 3.0
Keywords: IBM Cc: satya_minnekanti@…

Description

  1. Load the following content:
    <table border="1" cellpadding="1" cellspacing="1" >
    					<caption>table caption</caption>
    					<tbody><tr><td>cell</td></tr></tbody>
    				</table>
    
  2. Click inside the table caption and insert a horizontal line;
    • Actual Result: JavaScript error thrown.
    • Expected Result: block insertion should be disabled at the cursor position

Change History

comment:1 Changed 3 years ago by garry.yao

  • Status changed from new to confirmed

Same issue applies to the legend tag:

<form>
	<fieldset>
		<legend>fieldset^ legend</legend>
		height: <input type="text"/>
		weight: <input type="text"/>
	</fieldset>
</form>

comment:2 Changed 3 years ago by satya

  • Cc satya_minnekanti@… added

comment:3 Changed 2 years ago by satya

  • Keywords IBM added

comment:4 Changed 19 months ago by Reinmar

  • Status changed from confirmed to closed
  • Resolution set to fixed

Block elements can be now inserted into the table caption without a problem, because caption in HTML5 allows flow elements. However, legend element does not allow flow elements, but only phrasing, therefore insertion isn't possible.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy