Ticket #7955 (closed Bug: fixed)

Opened 4 years ago

Last modified 3 years ago

FF: with Auto grow plugin(with it's default configuration) PageUp & PageDown not working

Reported by: satya Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.6.3
Component: Core : Selection Version: 3.4
Keywords: IBM Firefox Cc: damo, jamescun, tmonahan

Description

To reproduce the defect:

  1. Open AutoGrow sample and enter content that spans multiple pages.
  1. Press PageUp button.

Expected Result: Cursor in editor body moves one page up.

Actual Result: Cursor goes out of editor body and we can't type in the editor.

Attachments

7955.patch (1.2 KB) - added by garry.yao 3 years ago.

Change History

comment:1 Changed 4 years ago by satya

  • Summary changed from FF: with Auto grow plugin PageUp & PageDown not working to FF: with Auto grow plugin(with it's default configuration) PageUp & PageDown not working

comment:2 Changed 4 years ago by j.swiderski

  • Status changed from new to confirmed
  • Version set to 3.4
  • Summary changed from FF: with Auto grow plugin(with it's default configuration) PageUp & PageDown not working to with Auto grow plugin(with it's default configuration) PageUp & PageDown not working

True for Firefox browsers from CKEditor 3.4. FF works fine when autoGrow_maxHeight is set but with default configuration the “Cursor goes out of editor body and we can't type in the editor”.

Few notes about IE (and Opera)
IE8, IE9 and Opera - with autoGrow_maxHeight there are no "pages", pressing page up moves cursor to the beginning of the text (no big deal). With default configuration pressing page-up moves the cursor to the beginning of the text but the browser doesn't scroll (Something like the first part of my comment in ticket #7946).

IE7 - with autoGrow_maxHeight set only the browser is scrolled. Default configuration works here.

IE6 - with autoGrow_maxHeight set scrolling works fine. With default configuration pressing page-up moves the cursor to the beginning of the text but the browser doesn't scroll just like IE9, IE8 and Opera.

In Webkit scrolling works.

comment:3 Changed 4 years ago by j.swiderski

The part about Opera and IE was described in ticket #7956.

comment:4 Changed 4 years ago by j.swiderski

  • Summary changed from with Auto grow plugin(with it's default configuration) PageUp & PageDown not working to FF: with Auto grow plugin(with it's default configuration) PageUp & PageDown not working

comment:5 Changed 4 years ago by satya

we will get the same error even when we set maxHeight to large vale(for ex: 5000px) and when there are no scroll bars for the entered content

comment:6 Changed 3 years ago by garry.yao

This's supposed to get fixed at #8050.

comment:7 Changed 3 years ago by tmonahan

This is still reproducible in the nightly builds. The issue in FF is particularly bad because it is not possible to type in the editor at all after the Page Up button is pressed. The cursor seems to get lost and users need to tab to the editor again or mouse click into it, to be able to enter text again.

comment:8 Changed 3 years ago by tmonahan

This is also an issue in FF when not using autogrow.

To reproduce:

  1. Open the replacebyclass sample.
  2. Enter a couple of lines of text. Note: Make sure the editor scroll bar does not appear.
  3. Press 'Page Up'

Problem: The cursor is now lost. It is not possible to enter text into the editor.

If you enter enough text to display the editor scroll bar, this issue does not occur.

An interesting thing to note is that when 'Page Up' is clicked, the Format drop down changes from 'Normal' to 'Heading 1'.

comment:9 follow-up: ↓ 10 Changed 3 years ago by garry.yao

The above tc WFM in latest FF.

comment:10 in reply to: ↑ 9 Changed 3 years ago by tmonahan

Replying to garry.yao:

The above tc WFM in latest FF.

Hi Garry, This testcase only works if the browser scroll bar is present. If you re-size your browser window so that the browser scroll bar appears and then re-try the steps above, you should be able to reproduce the issue. We actually believe this is a FF issue and we have logged a bug for it at https://bugzilla.mozilla.org/show_bug.cgi?id=695660. It would be good if you could comment on this ticket to try to escalate it's priority.

Is there any way CKEditor can workaround this issue until FF gets a fix?

Changed 3 years ago by garry.yao

comment:11 Changed 3 years ago by garry.yao

  • Status changed from confirmed to review
  • Owner set to garry.yao
  • Component changed from General to Core : Selection
  • Keywords Firefox added

The bug affects only when editor doc is not scrolled and page doc is scrolled, and I see a workaround within the editor is still feasible.

comment:12 Changed 3 years ago by fredck

  • Status changed from review to review_passed
  • Milestone set to CKEditor 3.6.3

Interesting solution.

Hopefully we'll be able to remove this hack from the code once the original Firefox bug gets fixed.

comment:13 Changed 3 years ago by garry.yao

  • Status changed from review_passed to closed
  • Resolution set to fixed

Fixed with [7369].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy