Ticket #7978 (closed Bug: fixed)

Opened 4 years ago

Last modified 3 years ago

IE: Can't open table properties dialog from context menu.

Reported by: j.swiderski Owned by:
Priority: Normal Milestone:
Component: General Version: 3.3.2
Keywords: IE Cc:

Description (last modified by garry.yao) (diff)

This bug is based on #7928 comment 3.

Third example : problem in IE 6, 7, 8, 9

  1. Create new table
  2. Put the cursor in the table
  3. Click 'table' in the elementspath
  4. Choose table properties in the context menu and change the height of the table to 200
  5. Click save
  6. Click on table properties in the context menu again: the menu item becomes selected, but the dialog does not open and you are blocked. (See Error.jpg)

It's not always reproducible. To reproduce it, after changing the height and saving (point 5), I had to place the cursor on one of the "selection squares" (see pic) so that the cursor changed to "resize cursor"(two oposite arrows). With that cursor, opening table properties dialog from menu is impossible.

I could reproduce it In IE9 from version 3.4.

In IE8, IE7 and IE6 from version 3.3.2 but in 3.3.2 after you change the height the table looses focus. You have to click once more on elementspath to select the table and then right-click on it. Once again it’s best to show right-click menu when cursor is changed to “resize cursor” although using “drag cursor” also has the same effect in this case.

Attachments

IE.png (20.9 KB) - added by j.swiderski 4 years ago.
Error.jpg (150.2 KB) - added by j.swiderski 4 years ago.

Change History

comment:1 Changed 4 years ago by j.swiderski

  • Status changed from new to confirmed

Changed 4 years ago by j.swiderski

comment:2 Changed 4 years ago by j.swiderski

  • Description modified (diff)

Changed 4 years ago by j.swiderski

comment:3 Changed 4 years ago by j.swiderski

  • Description modified (diff)
  • Summary changed from IE: Can't choose table properties from context menu. to IE: Can't open table properties dialog from context menu.

comment:4 Changed 4 years ago by garry.yao

  • Description modified (diff)

comment:5 Changed 3 years ago by naresh.sivaraman

I tested the issue mentioned here with CKEDITOR 3.6.1 and found that the issue has been fixed.

Can you please let me know the revision which has the fix for this issue. Please provide the link for the same.

comment:6 Changed 3 years ago by j.swiderski

  • Status changed from confirmed to closed
  • Resolution set to fixed

Seems it was fixed with rev [6971]

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy