Ticket #8158 (closed Bug: fixed)

Opened 3 years ago

Last modified 2 years ago

Adding a link to an image via toolbar fails if HTML comment is in image's DOM parent chain

Reported by: daniel.eric.lee Owned by:
Priority: Normal Milestone:
Component: General Version: 3.5.1
Keywords: Cc:

Description

Can be reproduced on the CKEditor demo page. 1) Go to http://ckeditor.com/demo 2) Click on 'Source' in the toolbar. Before the opening <h1>, add an HTML comment: <!-- this is a comment --> 3) Click on 'Source' again to toggle back to WYSIWYG mode. 4) Select the Little Red Riding Hood image. 5) On the toolbar, select the 'Link' button 6) Enter text for the link and click OK.

Result: Link Dialog does not close, image is not link-ified, JavaScript error appears in the console:

sibling.is is not a function

... /core/dom/range.js

Line 1032

It appears that range.js's 'enlarge' function is not taking HTML comments into account.

Change History

comment:1 Changed 3 years ago by j.swiderski

  • Status changed from new to confirmed
  • Version changed from 3.6.1 to 3.5.1

Reproducible form CKEditor 3.5.1.

JS Error:
Message: Object doesn't support this property or method.
Line: 1032
URI: /3.6.1/ckeditor/_source/core/dom/range.js

comment:2 Changed 2 years ago by j.swiderski

  • Status changed from confirmed to closed
  • Resolution set to fixed

I was not able to reproduce it in latest CKEditor 3.6.2.
Closing as fixed.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy