Opened 5 years ago

Closed 4 years ago

#8157 closed Bug (fixed)

IE8: We can't close Flash/Iframe dialog when dialog is over IFrame/Flash with dialog_startupFocusTab set to true

Reported by: satya Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.6.3
Component: Core : Selection Version: 3.5.3
Keywords: IBM IE8 Cc: damo, tmonahan

Description

To reproduce the defect:

  1. With dialog_startupFocusTab = true, paste the following code in source view and go back to rich text.
<iframe width="560" height="349" src="http://www.youtube.com/embed/39jtNUGgmd4" frameborder="0" allowfullscreen></iframe>
  1. Bring up IFrame dialog by opening context menu on IFrame.
  1. click OK button to close the dialog.

Issue: we can't close the dialog, when we drag the dialog away from the IFrame or Flash we can close it.

Attachments (3)

IE8.png (36.3 KB) - added by j.swiderski 5 years ago.
8157.patch (1.4 KB) - added by garry.yao 4 years ago.
8157_2.patch (1.7 KB) - added by garry.yao 4 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 5 years ago by j.swiderski

  • Keywords IE8 added
  • Status changed from new to confirmed
  • Version set to 3.5.3

Reproducible form CKE 3.5.3. Unfortunatelly I was not able to find revision for this one. Sorry.

If you roght-click on frame placeholder it gets selected and when dialog appears it looks like it is under the selected area (selection squares are above dialog- see attached pic).

Changed 5 years ago by j.swiderski

comment:2 Changed 5 years ago by tmonahan

Is there any update on this issue?

Changed 4 years ago by garry.yao

comment:3 Changed 4 years ago by garry.yao

  • Owner set to garry.yao
  • Status changed from confirmed to review

comment:4 Changed 4 years ago by fredck

  • Status changed from review to review_failed

Bad code:

  • The new native var is to be reused for the IE8 case.
  • We need just one if, first checking IE8< and then native.type. empty() may be called twice otherwise.
  • debugger!

Changed 4 years ago by garry.yao

comment:6 Changed 4 years ago by garry.yao

  • Status changed from review_failed to review

comment:7 Changed 4 years ago by fredck

Better to have #8815 closed before reviewing this one.

comment:8 Changed 4 years ago by fredck

  • Component changed from General to Core : Selection
  • Milestone set to CKEditor 3.6.3
  • Status changed from review to review_passed

comment:9 Changed 4 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from review_passed to closed

Fixed with [7402].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy