Ticket #8287 (closed Bug: invalid)

Opened 3 years ago

Last modified 19 months ago

Internet explorer Frameset issue

Reported by: KevenD Owned by:
Priority: Normal Milestone:
Component: General Version: 3.2
Keywords: IE9 Cc:

Description

When using Internet Explorer 9 in a page within a frameset the CKeditor instance's menu bar covers the entire document and the editor area can not be seen. This is the same with FCKEditor 2.x as well which I tried as a back up. Pulled from the frameset the exact sane page works fine.

Page works in frameset under Firefox, Opera, Chrome and Safari.

Attachments

CKeditor_frameset.JPG (159.4 KB) - added by KevenD 3 years ago.
Shows the same page in frameset with IE on left and Chrome on right.
frameset.zip (3.0 KB) - added by j.swiderski 3 years ago.
HowFreamesetShouldLookLike.zip (749 bytes) - added by j.swiderski 19 months ago.

Change History

Changed 3 years ago by KevenD

Shows the same page in frameset with IE on left and Chrome on right.

comment:1 follow-up: ↓ 2 Changed 3 years ago by j.swiderski

  • Status changed from new to pending

I couldn't reproduce the issue.

Could I ask you to provide a sample test case file that would help reproduce the problem?

comment:2 in reply to: ↑ 1 Changed 3 years ago by KevenD

Replying to j.swiderski:

I couldn't reproduce the issue.

Could I ask you to provide a sample test case file that would help reproduce the problem?

FRAMESET: http://bcalpine.com/ck/troubleshooting/frames.html

RIGHT FRAME BY ITSELF: http://bcalpine.com/ck/troubleshooting/frame2/

Only IE9 has the issue. I find that using compatibility mode sometimes fixes it, sometimes not.

comment:3 follow-up: ↓ 5 Changed 3 years ago by j.swiderski

  • Status changed from pending to confirmed
  • Keywords IE9 added
  • Version changed from 3.6.1 to 3.2
  1. Put test case files from attachment into samples folder
  2. Open framset.html sample.

Result: Content area is not visible.
This is because page frame2.html has no doctype thus main page is displayed in "IE9 mode" and frame2 in "quirks mode". From what I have spoken with @wwalc IE9 has problems with let's say working with more than one mode.

A workaround to the problem is to add doctype in frame2.html

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">

or

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> 

Issue has been reproducible from CKE 3.2

Changed 3 years ago by j.swiderski

comment:5 in reply to: ↑ 3 Changed 3 years ago by KevenD

Replying to j.swiderski:

Perfect solution, thank you!

I just hope someone knows a solution for my other issue http://dev.ckeditor.com/ticket/8288 and then IE users will stop complaining to me! :)

comment:6 Changed 19 months ago by j.swiderski

  • Status changed from confirmed to closed
  • Resolution set to invalid

#9807 was marked as duplicate.

Please note that frames are dead now. If you still want to use them please note that mixing doctypes is not way to go.
After consulting this issue with my colleagues we have decided to close it with couple of guide lines (based on users’ mistakes):

  1. You can't use HTML5 doctype declaration for frameset. Frames are not supported in HTML5. HTML4 frameset declaration is needed here.
  2. Don't forget to use head section in frameset page
  3. Don't forget to put doctype declaration (HTML4 transitional or loose) in frame page because you will get in mixed doctypes and errors.

Please have a look attached zip file - it shows how frames should be used.

Changed 19 months ago by j.swiderski

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy