Ticket #8286 (closed Bug: duplicate)

Opened 3 years ago

Last modified 3 weeks ago

Opera: paste from right-click menu does nothing

Reported by: mike1 Owned by:
Priority: Normal Milestone:
Component: Core : Pasting Version: 3.5
Keywords: Opera Cc:

Description

If I create CKEditor instance with empty initial text and disabled context menu, copy some text to clipboard, paste it through right-click Opera standard menu, nothing happens. It works only on second or third time.

Opera version is 11.50 english.

My config is <script type="text/javascript">

CKEDITOR.replace( 'editor_office2003',

{

skin : 'office2003', removePlugins : 'contextmenu'

});

</script>

Change History

comment:1 Changed 3 years ago by j.swiderski

  • Keywords Opera added
  • Status changed from new to pending
  • Version set to 3.5

Context native menu for pasting has been visible in Opera form CKEditor 3.5.

I didn't get the error you were talking about but something similar.
If you put mouse cursor below editor cursor (the one blinking in content area) than no pasting will take place.
If you put mouse cursor in the same line/height as editor cursor (the one blinking in content area) than pasting takes place.

@mike1 is this what you are getting?

comment:2 Changed 3 years ago by j.swiderski

@mike1 any updates?

comment:3 Changed 3 years ago by mike1

Yes, this is the native Opera context menu (right-click->Paste).

In my case incorrect behaviour (no pasting) usually takes place in case of empty content area. I can paste normally if the content area is not empty (even one space resolves the problem) and if the mouse cursor is on the same line with the editor cursor. And, yes, the effect depends on the mouse cursor position. BTW, another Opera paste option (Opera button->Page->Paste) works normally even on empty editor window.

I also noticed that in Firefox right-clicking on editor area raises different context menus depending on the point where mouse pointer is: either frame menu with no paste option at all or normal cut/copy/paste menu. Maybe Opera just shows incorrect context menu when no paste option is available and so it does not work?

Last edited 3 years ago by mike1 (previous) (diff)

comment:4 Changed 3 years ago by j.swiderski

  • Status changed from pending to confirmed

I must say that it didn't matter for me whether there was a content in editor or not. If the mouse cursor was in the same line as editor cursor the pasting took place otherwise not.

This issue worked till CKEditor version 3.5.

comment:5 Changed 3 years ago by mike1

Ok, you are right. When can this problem possible be solved?

comment:6 Changed 3 weeks ago by j.swiderski

  • Status changed from confirmed to closed
  • Resolution set to duplicate

This issue is in fact a duplicate of #7979.

Currently the only workaround is setting CSS rule min-height for body so that it covers visible content area.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy