Opened 5 years ago

Closed 4 years ago

#8305 closed Bug (fixed)

Adding a LTR Paragraph to RTL List changing language direction of list

Reported by: satya Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.6.3
Component: Core : Lists Version: 3.0
Keywords: IBM Cc: damo, tmonahan

Description

  1. Paste the following code in to souce view
<ol dir="rtl">
	<li>
		first list item</li>
</ol>
<p dir="ltr"> LTR Paragraph </p>
  1. Go back to rich text keep cursor in LTR Paragraph and click on Numbered List button.

Expected Result: List remains RTL and dir=rtl applied to second list item.

<ol dir="rtl">
	<li>
		first list item</li>
	<li dir="ltr">
		LTR Paragraph</li>
</ol>

Actual Result: List becomes LTR

<ol>
	<li>
		first list item</li>
	<li dir="ltr">
		LTR Paragraph</li>
</ol>

Attachments (1)

8305.patch (2.4 KB) - added by garry.yao 4 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 5 years ago by j.swiderski

  • Status changed from new to confirmed
  • Version set to 3.0

Reproducible in all browsers from CKE 3.0.

comment:2 Changed 5 years ago by satya

Scenario mentioned in this ticket is exactly opposite to the scenario mentioned in ticket #7448 which is fixed in 3.6.2. Fix applied for ticket #7448 should also target the scenario mentioned in this ticket.

Changed 4 years ago by garry.yao

comment:3 Changed 4 years ago by garry.yao

  • Owner set to garry.yao
  • Status changed from confirmed to review

New impl handles both #7448 and this case, also, with an additional change that perserve the root element of existing list instead of the newly created one when merging, in short, merge new to old, this should be more intuitive.

Because of the relativity, new tcs are added back to the origin tt:

http://ckeditor.t/tt/7448/1.html

comment:4 Changed 4 years ago by fredck

  • Component changed from General to Core : Lists
  • Milestone set to CKEditor 3.6.3
  • Status changed from review to review_passed

comment:5 Changed 4 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from review_passed to closed

Fixed with [7403].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy