Ticket #8306 (confirmed Bug)

Opened 3 years ago

Last modified 3 years ago

FF : Custom attributes on links dropped during copy/paste

Reported by: jon.kuhl Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: Firefox CantFix VendorFix Cc:

Description

Custom attributes on anchor tags are being dropped during copy/paste (Ctrl+C/Ctrl+V).

Steps to reproduce:

  1. In Source mode, modify a standard link by adding a custom attribute (e.g. <a href="/index.htm" customAttribute="1">test</a>.)
  2. Switch out of source mode.
  3. Copy (Ctrl+C) the linked text.
  4. Paste (Ctrl+V) on a new line.
  5. Switch back to Source mode, and see that customAttribute="1" was not pasted.

Occurs on the demo page with the following environments:

  • Browser: FF6 OS: Windows Vista, Windows 7
  • Browser: FF5 OS: Mac
  • Browser: FF3 OS: Windows Vista

Change History

comment:1 Changed 3 years ago by j.swiderski

  • Keywords Firefox added
  • Status changed from new to confirmed
  • Version changed from 3.6.1 to 3.0

Reproducible in Firefox browsers from CKEditor 3.0

comment:2 Changed 3 years ago by alfonsoml

  • Status changed from confirmed to closed
  • Resolution set to duplicate

Dup of #6631

comment:3 Changed 3 years ago by j.swiderski

  • Keywords CantFix VendorFix added
  • Status changed from closed to reopened
  • Resolution duplicate deleted

This issue is a duplicate of #6631 and 6631 is a duplicate of #6275.

But ticket #6275 is set to fixed while issue with droping custom attributes in E.g. links or images when copy/paste is still reproducible.

I'm reopening this issue with keywords CantFix and VendorFix to indicate that issue occurs and this is Firefox specific problem with which we can't do much.

Last edited 3 years ago by j.swiderski (previous) (diff)

comment:4 Changed 3 years ago by j.swiderski

  • Status changed from reopened to confirmed
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy