Opened 5 years ago

Closed 6 months ago

Last modified 6 months ago

#8401 closed Bug (duplicate)

Accessibility: Problems navigating radio buttons in a dialog using the keyboard

Reported by: tmonahan Owned by:
Priority: Normal Milestone:
Component: Accessibility Version: 3.2
Keywords: IBM Cc: damo, satya

Description

When radio buttons are included in a dialog, keyboard navigation does not work correctly.

The following issues occur:

  1. When radio buttons are the first focusable element on the dialog, it is not possible to tab to them.
  1. If there is a focusable element before the radio buttons, it is necessary to tab twice to enter the radio button group.
  1. Once inside a radio button group, it is not possible to exit the radio button group by pressing tab.

To reproduce, add the following UI element to a dialog and try to navigate through it using only the keyboard:

{
	type : 'fieldset',
	label : 'Radio Buttons',
	children :
	[
		{
			type : 'radio',
			id : 'type',
			required : true,
			'default' : 'one',
			items :
			[
				[ 'Radio1', 'one' ],
				[ 'Radio2', 'two' ]
			]
		}
	]
}

Change History (8)

comment:1 Changed 5 years ago by j.swiderski

  • Status changed from new to confirmed
  • Version changed from 3.6.2 to 3.2

comment:2 follow-ups: Changed 18 months ago by Reinmar

  • Resolution set to duplicate
  • Status changed from confirmed to closed

DUP of #8401.

comment:3 in reply to: ↑ 2 Changed 17 months ago by satya

Replying to Reinmar:

DUP of #8401.

hi Reinmar please re-open this defect, you marked the defect as a duplicate of itself which does not make any sense.

comment:4 Changed 17 months ago by Reinmar

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Oops, that's true. Now I'm wondering if there was a DUP somewhere and I just pasted the wrong ticket number...

comment:5 Changed 17 months ago by Reinmar

  • Status changed from reopened to confirmed

comment:6 in reply to: ↑ 2 Changed 6 months ago by m.lewandowski

Replying to Reinmar:

DUP of #8401.

I believe @Reinmar simply meant to put #8194 as a source of DUP. And in fact it does look like one.

Not reproducible anymore since CKE 4.3.0.

comment:7 Changed 6 months ago by m.lewandowski

  • Resolution set to duplicate
  • Status changed from confirmed to closed

DUP of #8194.

comment:8 Changed 6 months ago by Anna

  • Summary changed from Accessibility: Problems navigating radio buttons on a dialog using the keyboard to Accessibility: Problems navigating radio buttons in a dialog using the keyboard
Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy