Ticket #8402 (confirmed Bug)

Opened 3 years ago

Last modified 7 months ago

SSI-style HTML comments inside href attributes are broken when Source button is clicked

Reported by: Jordan Bradford Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.2
Keywords: Cc:

Description

SSI-style HTML comments such as <!--#echo var='DOCUMENT_NAME' --> become broken when the Source button is clicked.

Example:

Using the CKEditor demo site, click the Source button and add that comment to the first link:

<a href="http://en.wikipedia.org/wiki/Fairy_tale/<!--#echo var='DOCUMENT_NAME' -->" title="Fairy tale">fairy tale</a>

Then click Source to view the content in the normal editor mode. When you click Source again, the link becomes this:

<a href="http://en.wikipedia.org/wiki/Fairy_tale/{C}<!--#echo var='DOCUMENT_NAME' -->" title="Fairy tale">fairy tale</a>

Note the {C} that has been added. In fact, every time the source is viewed, another {C} is added:

<a href="http://en.wikipedia.org/wiki/Fairy_tale/{C}{C}<!--#echo var='DOCUMENT_NAME' -->" title="Fairy tale">fairy tale</a>
<a href="http://en.wikipedia.org/wiki/Fairy_tale/{C}{C}{C}<!--#echo var='DOCUMENT_NAME' -->" title="Fairy tale">fairy tale</a>

and so on.

Change History

comment:1 Changed 3 years ago by j.swiderski

  • Status changed from new to closed
  • Resolution set to duplicate

DUP of #8216

comment:2 Changed 7 months ago by Reinmar

  • Status changed from closed to reopened
  • Resolution duplicate deleted

I'm reopening this ticket, because it wasn't fixed together with #8216, so it might look as a duplicate, but it's a different case apparently.

comment:3 Changed 7 months ago by Reinmar

  • Status changed from reopened to confirmed
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy