Ticket #8403 (closed Bug: duplicate)

Opened 3 years ago

Last modified 3 years ago

IE: Pasting content from notepad which includes blank lines is not working correctly

Reported by: tmonahan Owned by:
Priority: Normal Milestone:
Component: Core : Pasting Version: 3.6.2
Keywords: IBM CantFix Cc: damo, satya

Description

When text content in notepad contains blank lines and it is pasted into CKEditor, some of the blank lines are removed in IE. In FF, this works correctly.

To reproduce, paste the following content into notepad and then into CKEditor in IE:

aaaa


bbbb

cccc

dddd

Note: There are 2 blank lines between 'aaaa' and 'bbbb' in this sample content and one blank line between the remaining content.

However when this content is pasted into CKEditor in IE, there is only one blank line between 'aaaa' and 'bbbb', and there are no blank lines in the remainder of the content.

The markup generated for this in source view is different in IE and FF:

HTML in IE:

<p>
	aaaa</p>
<p>
	<br />
	bbbb</p>
<p>
	cccc</p>
<p>
	dddd</p>

HTML in FF:

<p>
	aaaa<br />
	<br />
	<br />
	bbbb<br />
	<br />
	cccc<br />
	<br />
	dddd</p>

Change History

comment:1 Changed 3 years ago by j.swiderski

  • Keywords CantFix added
  • Status changed from new to closed
  • Resolution set to duplicate

This is a duplicate of #7622 which is a WontFix issue.

comment:2 Changed 3 years ago by tmonahan

Ticket #7622 suggests using 'Paste as Plain Text' as a workaround for this issue. However the same problem occurs when we use 'Paste as Plain Text' in the usecase above. Is this also due to pre-processing by the browser or should 'Paste as Plain Text' work differently and therefore avoid this problem?

comment:3 Changed 3 years ago by j.swiderski

  • Status changed from closed to reopened
  • Resolution duplicate deleted

comment:4 Changed 3 years ago by j.swiderski

  • Status changed from reopened to closed
  • Resolution set to duplicate

Ticket #7622 suggests using 'Paste as Plain Text' as a workaround for this issue. However >the same problem occurs when we use 'Paste as Plain Text' in the usecase above. Is this >also due to pre-processing by the browser or should 'Paste as Plain Text' work >differently and therefore avoid this problem?

In 'Paste as Plain Text' results are the same across browsers but it seems that there is a bug in 'Paste as Plain Text' - empty lines are lost . It was working as expected till CKE 3.0.2.

This bug speaks about differences in browsers when pasting from notepad, so I will leave it closed as it a duplicate of #7622 but I will confirm #8404 (it addresses the issue better) and add a extra comment saying that the same thing happens when user pastes such text taken from Notepad.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy