Ticket #8413 (closed Bug: fixed)

Opened 3 years ago

Last modified 2 years ago

Link editor freezes when comments exists between tables

Reported by: bmohrct Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.6.3
Component: Core : Styles Version: 3.5.1
Keywords: Cc: bmohr@…

Description (last modified by j.swiderski) (diff)

This bug was reported as fixed in ticket #8232 but I am able to replicate the fix. The style/plugin.js file does not exist in my /plugins/style dir. I have however been able to better narrow down the issue. It is not an option for me to delete comments since this fix applies to many preexisting files.

I replicated the issue in the ckeditor demo by creating two tables with a HTML comment between each table. Then added text to a cell after the comment and tried to make it a link. The link editor freezes. The following HTML will create the same error:

<table>
	<tbody>
		<tr>
			<td>
				&nbsp;</td>
			<td>
				&nbsp;</td>
		</tr>
	</tbody>
</table>
<!-- TEST COMMENT -->
<table>
	<tbody>
		<tr>
			<td>
				asdf</td>
			<td>
				&nbsp;</td>
		</tr>
	</tbody>
</table>
<p>
	&nbsp;</p>

The result adds span tags around the text and does not create a link.

This was replicated FF on OSX.

Attachments

8413.patch (2.7 KB) - added by garry.yao 2 years ago.

Change History

comment:1 Changed 3 years ago by j.swiderski

  • Status changed from new to confirmed
  • Version changed from 3.6.1 to 3.5.1
  • Description modified (diff)

Issue is reproducible in all browsers from CKEditor 3.0.

Message: sibling.is is not a function.
Line: 1032
URI: /3.6.2/ckeditor/_source/core/dom/range.js

comment:2 Changed 3 years ago by bmohrct

Are there any updates or ETA for this bug? It is currently preventing up from migrating to ckeditor.

comment:3 Changed 2 years ago by bmohrct

I have confirmed that this issue still occure in 3.6.2. Is there any plan to address this in the near future. It has prevented up from upgrading.

Changed 2 years ago by garry.yao

comment:4 Changed 2 years ago by garry.yao

  • Owner set to garry.yao
  • Status changed from confirmed to review
  • Component changed from General to Core : Styles
  • Milestone set to CKEditor 3.6.3

Target to milestone because of the bug severity.

comment:5 Changed 2 years ago by j.swiderski

@bmohrct - could you perhaps test the patch provided by @garry.yao and see if it works?

comment:6 Changed 2 years ago by fredck

  • Status changed from review to review_passed

comment:7 Changed 2 years ago by garry.yao

  • Status changed from review_passed to closed
  • Resolution set to fixed

Fixed with [7372].

comment:8 Changed 2 years ago by wwalc

Just a note, that the constructor variable used in the patch for node.js is not accepted by Rhino (org.mozilla.javascript.Parser). The returned error is "identifier is a reserved word" - the variable name must be changed into anything else.

comment:9 Changed 2 years ago by garry.yao

Ok, this's addressed with [7375].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy