Ticket #8495 (closed Bug: invalid)

Opened 3 years ago

Last modified 3 years ago

Textarea disappears when switching to source in IE 8/9

Reported by: pfibbe Owned by:
Priority: Normal Milestone:
Component: UI : Source View Version:
Keywords: Cc:

Description

When switching to 'Source' the textarea disappears. This is caused by the following code in /plugins/sourcearea/plugin.js:66:

textarea.hide(); textarea.setStyle( 'height', holderElement.$.clientHeight + 'px' );

Because of the hiding of the textarea the height of the holderElement.$ is reduced to 0 and so the textarea becomes invissible. I can't find a reason why this height would not be initialized BEFORE hiding the textarea, it it possible to do so?

var clientHeight = holderElement.$.clientHeight; textarea.hide(); textarea.setStyle( 'height', clientHeight + 'px' );

We are using the ckeditor in an 'absolute positioned environment', which is working fine, but on a rare occasion needs some adjustment which we put in a separate file. Since this will only be for the better of the ckeditor itself and won't effect any existing behaviour in other browsers it would be nice to have it fixed this way.

Tested on the nighlty build as well.

Change History

comment:1 Changed 3 years ago by pfibbe

  • Component changed from General to UI : Source View

comment:2 Changed 3 years ago by j.swiderski

  • Status changed from new to pending
  • Version 3.6.3 (SVN - trunk) deleted

I was not able to reproduce it in plain CKEditor.

Is the issue reproducible in E.g. http://ckeditor.com/demo or only in your webapp?
Which version of CKEditor you are talking about? Could you perhaps provide a reduced test case showing the problem?

comment:3 Changed 3 years ago by j.swiderski

@pfibbe could I ask you for more details about this bug or it was only reproducible in your webapp?

comment:4 Changed 3 years ago by pfibbe

Sorry for being unclear about it, we can only reproduce it in our webapp.

Since 3.5.3 we have tried some ways to scale the ckeditor with the resizing of the window, which seemed (and still seems? --> http://dev.ckeditor.com/ticket/4454) to be quite difficult and some problems seem to appear to keep everything working correctly. For example when increasing the table height (.cked_editor) the height of all containing TR elements is increased as well, which is't desirable for the toolbar TR element). Besides that we are also using a self made plugin to switch between toolbars. For these and some other minor issues some scaling adjustments needed to be made as well.

Again, we have therefor developed a plugin to correct these problems and obviously want to minimize that. We can of course work around this issue in our own plugin, but looking at the Ckeditor source code a modification at the location as described in this issue makes me wonder why calculating the height after hiding the element, could be a reason for, but therefor our request. It would be a good help for us and doesn't seem to cause regression (not in FF/Chrome).

We are using version 3.6.2 and have also tried it with 3.6.3.

comment:5 Changed 3 years ago by j.swiderski

  • Status changed from pending to closed
  • Resolution set to invalid

The problem is that if there is no impact on 'default' CKEditor and only on customized one we can't treat such bug as valid.

I’m sorry but if you are not able to show that this part of code has impact on not customized CKEditor than I will have to close this ticket.

Any reduced test case files proving the problem exists in ‘default’ CKEditor are welcome and will allow to look into the buig once more.

comment:6 Changed 3 years ago by pfibbe

Understandable, thanks for looking into it anyway.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy