Ticket #8496 (closed Bug: invalid)

Opened 2 years ago

Last modified 2 years ago

Cannot break bulleted item out of list

Reported by: mrfr0g Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.2
Keywords: Cc: mcamden@…

Description

If you have a list of three items, and place your cursor at the start of the second item and press enter, I would expect the content to split in to a list, paragraph and list. Instead additional bullets are created giving no way of breaking an item out of the list.

Steps to reproduce:

  1. Goto, http://ckeditor.com/demo
  2. Create a list with three items
  3. Place your cursor at the start of the second item, and press enter.

Expected behavior: The list would split in to three elements, a list on top, a paragraph in the center, and a list on the bottom.

Actual behavior: Additional bullets are created.

In Chrome/FF (Latest) pressing backspace will bring the item to the end of the previous item. In IE, pressing backspace will break the item out of the list.

Change History

comment:1 Changed 2 years ago by j.swiderski

  • Status changed from new to closed
  • Resolution set to invalid

This is how it works by design.

I don’t think that this is some unspoken rule for editors but even MS Word works that way.

If you want to break out of the list you should place the cursor at the end of the item and not at the beginning.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy