Opened 4 years ago

Closed 4 years ago

#8855 closed Bug (fixed)

Popup not working on Chrome 18

Reported by: Saare Owned by: Saare
Priority: Normal Milestone: CKEditor 3.6.3
Component: General Version:
Keywords: Chrome Cc:

Description (last modified by Saare)

Not affecting Safari, or Chrome 17 or 19.
Chrome 18 is problematic with moveTo and resizeTo, making the window to not show up.
See this and that. Since that part of the code is not needed in Chrome 18, I propose to avoid it altogether. Note that WebKit 535 is maintained since Chrome 13 till Chrome 18.

Attachments (2)

8855.patch (670 bytes) - added by Saare 4 years ago.
popup.patch (967 bytes) - added by luckytp 4 years ago.
Path to fix open popup in chrome

Download all attachments as: .zip

Change History (14)

Changed 4 years ago by Saare

comment:1 Changed 4 years ago by Saare

  • Owner set to Saare
  • Status changed from new to review

comment:2 Changed 4 years ago by Saare

  • Description modified (diff)

comment:3 Changed 4 years ago by garry.yao

  • Status changed from review to review_failed

I wonder if we really need to the chunk of code for popup position, consider that the position is already a cross-browser feature for window.open, so we can simply remove it.

comment:4 Changed 4 years ago by j.swiderski

#8860 was marked as duplicate.

comment:5 Changed 4 years ago by Saare

  • Status changed from review_failed to review

I believe that there's a reason this code is there, so to avoid wider testing on this simple issue, I would leave it there. We could definitely consider removing it later, but for now let's make sure we don't cause any new problems.

comment:6 Changed 4 years ago by Anna

#8863 was marked as duplicate.

comment:7 Changed 4 years ago by garry.yao

  • Status changed from review to review_passed

comment:8 Changed 4 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from review_passed to closed

Fixed with [7448].

comment:9 Changed 4 years ago by jonespm

This appears to be broken again in 20.0.1132.34 beta-m. :/

So if the 7448 workaround was just to work around version 18, hopefully it won't be an issue when 20 is released.

comment:10 Changed 4 years ago by lencinhaus

Wouldn't be quite sure about that: http://code.google.com/p/chromium/issues/detail?id=2091 They restored the old behavior, the issue has been in "Won't fix" status for 4 years and the only comment by chromium devs is "This is by design". Hope you are right, it seems a silly behavior to me.

comment:11 Changed 4 years ago by j.swiderski

  • Resolution fixed deleted
  • Status changed from closed to reopened

I have just checked Chrome 20 and this issue has showed up again in CKEditor and CKFinder.

comment:12 Changed 4 years ago by j.swiderski

  • Resolution set to fixed
  • Status changed from reopened to closed

Sorry for opening already closed ticked.

For Chrome 20 new ticket #9069 was opened.

Changed 4 years ago by luckytp

Path to fix open popup in chrome

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy