Ticket #8883 (closed Bug: fixed)

Opened 2 years ago

Last modified 13 months ago

Firefox: Dragging image wrapped in block element leaves empty block elements in content area.

Reported by: j.swiderski Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.2
Keywords: Firefox Cc:

Description

  1. Go to http://ckeditor.com/demo
  2. Drag image in few places inside content area
  3. Switch to source and notice that there are many empty headers inside content area <h1>&nbsp;</h1>

I have also tried using the below code (img inside div)

<div>
	<img alt="" src="http://a.cksource.com/c/1/inc/img/demo-little-red.jpg" style="margin-left: 10px; margin-right: 10px; float: left; width: 120px; height: 168px;" /></div>
<h1>Little Red Riding Hood</h1>

Code didn't cause much trouble except for the first two drags. First one leaves empty div at the top and second one (Let's say picture was dragged here in the first try rescue and cuts the w^olf )and the second one leaves empty div inside text. In all other cases picture is dragged without div anymore.

Issue reproducible in Firefox from CKEditor 3.6.2 rev [7242]

Change History

comment:1 Changed 2 years ago by j.swiderski

  • Status changed from new to confirmed

comment:2 Changed 2 years ago by j.swiderski

  • Summary changed from Firefox: Draggin image wrapped in block element leaves empty bolck elements in content area. to Firefox: Dragging image wrapped in block element leaves empty block elements in content area.

comment:3 Changed 2 years ago by j.swiderski

Till version 3.6.1 when dragging image placed inside a div it split paragraphs.

Edit:
Which is rather ok because img was wrapped in div and since div can't be placed inside p it split paragraphs in two. Sorry for this comment.

To summarize: Till version 3.6.1 image was dragged with surrounding div

Last edited 2 years ago by j.swiderski (previous) (diff)

comment:4 Changed 2 years ago by j.swiderski

This ticket is related to #8884. Same TC, similar results, different versions.

comment:5 Changed 13 months ago by j.swiderski

  • Status changed from confirmed to closed
  • Resolution set to fixed

Seems this issue is no longer reproducible in latest CKEditor 4.1 and latest firefox 20.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy