Ticket #8949 (closed Bug: fixed)

Opened 3 years ago

Last modified 2 years ago

IE: Image Properties does not show in context menu when the image is wrapped in a div with the width set

Reported by: jamescun Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.6.4
Component: UI : Context Menu Version: 3.6.3
Keywords: IE IBM Cc: damo, satya, tmonahan

Description

Steps to reproduce the defect:

  1. Open CKEditor in IE.
  2. Paste the code below into the source view.
<div style="width: 700px">
	<img alt="" src="http://www.attackingsoccer.com/wp-content/uploads/2011/07/Shamrock-Rovers-logo.jpg" /></div>

This code is simply an image wrapped inside a div and the div has a width of 700px.

  1. Switch back to WYSIWYG mode.
  2. Right click anywhere on the image.

Expected Result: The context menu is displayed and it contains an option to open the Image Properties dialog.

Actual Result: The context menu appears but there is no Image Properties option

This defect was introduced with this changeset http://dev.ckeditor.com/changeset/7404

N.B. Similar behaviour can be seen when the image is also a link (see code below) and sometimes the Edit Link/Remove Link options also do not appear in the context menu.

<div style="width: 700px">
	<a href="http://www.attackingsoccer.com/wp-content/uploads/2011/07/Shamrock-Rovers-logo.jpg"><img alt="" src="http://www.attackingsoccer.com/wp-content/uploads/2011/07/Shamrock-Rovers-logo.jpg" /></a></div>

Attachments

revision_7403.JPG (152.3 KB) - added by jamescun 3 years ago.
Revision 7403
revision_7404.JPG (152.6 KB) - added by jamescun 3 years ago.
Revision 7404
8949.patch (928 bytes) - added by garry.yao 2 years ago.

Change History

comment:1 Changed 3 years ago by j.swiderski

  • Status changed from new to closed
  • Resolution set to duplicate

I have double-checked this issue and my results are as follows: Reproducible from CKEditor 3.2.2 and only in IE6-8 while working in IE9, what makes this bug a DUP of #5812.

@jamescun I could not reproduce this problem from rev [7404]. Could you check it once more on your end?

comment:2 Changed 3 years ago by jamescun

@j.swiderski I disagree that this is a DUP of #5812.

http://dev.ckeditor.com/ticket/5812 states

Note that the first time I right click the image I don't get the 
"Image Properties" option. However, if I then right-click on the image
 again OR if I left click the image and then click the Image button, 
I get the "Image Properties" option and the dialog loads correctly. 

However, after http://dev.ckeditor.com/changeset/7404 was delivered, the Image Properties option NEVER appears in the context menu no matter how many times you right click on the image.

I have supplied 2 screenshots to illustrate the behaviour of the context menu at revision 7403 and revision 7404.

N.B. This works fine in IE9.

Changed 3 years ago by jamescun

Revision 7403

Changed 3 years ago by jamescun

Revision 7404

comment:3 Changed 3 years ago by j.swiderski

  • Status changed from closed to reopened
  • Keywords IE added
  • Resolution duplicate deleted

Note that the first time I right click the image I don't get the "Image Properties" option.

However, after http://dev.ckeditor.com/changeset/7404 was delivered, the Image Properties option NEVER appears in the context menu no matter how many times you right click on the image.

@jamescun good catch. Seems that rev. [7404] has introduced new variation of the problem reported in #5812. Sorry I’ve missed that.

Problem reproducible from CKEditor 3.6.3 rev [7404] in IE6-8. Please also have a look at #5812.

comment:4 Changed 3 years ago by j.swiderski

  • Status changed from reopened to confirmed

Changed 2 years ago by garry.yao

comment:5 Changed 2 years ago by garry.yao

  • Status changed from confirmed to review
  • Owner set to garry.yao

comment:6 Changed 2 years ago by garry.yao

#5812 has been marked as DUP.

Last edited 2 years ago by garry.yao (previous) (diff)

comment:7 Changed 2 years ago by fredck

  • Status changed from review to review_passed
  • Milestone set to CKEditor 3.6.4

comment:8 Changed 2 years ago by garry.yao

  • Status changed from review_passed to closed
  • Resolution set to fixed

Fixed with [7496].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy