Ticket #9109 (closed Bug: invalid)

Opened 2 years ago

Last modified 2 years ago

Found few bugs/questions

Reported by: bsm0206 Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Hi,

My name is Steve Bang. I am trying to purchase the richtext editor that can work best for my clients. I tested some cases on the demo, and found some questions. I will attach the document file. Please let me know if you have any questions about it.

Thank you. Steve Bang

Attachments

CKEditor Questions.doc (147.0 KB) - added by bsm0206 2 years ago.
List of questions
CKEditor Questions 2.doc (48.5 KB) - added by bsm0206 2 years ago.

Change History

Changed 2 years ago by bsm0206

List of questions

comment:1 follow-up: ↓ 5 Changed 2 years ago by j.swiderski

  • Status changed from new to pending
  1. Please use (invalid report)
    config.pasteFromWordRemoveFontStyles=false;
    config.pasteFromWordRemoveStyles=false;
    
  1. We have tickets reported for it already (duplicated report):

http://dev.ckeditor.com/ticket/7853
http://dev.ckeditor.com/ticket/844
http://dev.ckeditor.com/ticket/717
http://dev.ckeditor.com/ticket/7141

  1. I will need more information here. What are the exact steps to reproduce the problem (what to insert, how, where to put cursor etc.) and in which browser and version of CKEditor does it happen?
  2. The same as in point 3.

Changed 2 years ago by bsm0206

comment:2 Changed 2 years ago by bsm0206

Thanks for the quick reply. I attached "CKEditor Questions 2.doc" Please let me know if you have any questions.

comment:3 Changed 2 years ago by wwalc

@Steve - please add comments directly here on the dev site instead of using Word documents. It's hard to search for issues when the description is hidden in binary files. Also it's hard to read such issues on devices where MS Word is not available.

comment:4 Changed 2 years ago by j.swiderski

@Steve - As for the issue no3 I think it needs more testing. There are some differences between browsers. I will get back to you once I'm finished.

comment:5 in reply to: ↑ 1 Changed 2 years ago by bsm0206

For #2, I do not see the answers. Can you explain in detail?

Thank you. Steve

Replying to j.swiderski:

  1. Please use (invalid report)
    config.pasteFromWordRemoveFontStyles=false;
    config.pasteFromWordRemoveStyles=false;
    
  1. We have tickets reported for it already (duplicated report):

http://dev.ckeditor.com/ticket/7853
http://dev.ckeditor.com/ticket/844
http://dev.ckeditor.com/ticket/717
http://dev.ckeditor.com/ticket/7141

  1. I will need more information here. What are the exact steps to reproduce the problem (what to insert, how, where to put cursor etc.) and in which browser and version of CKEditor does it happen?
  2. The same as in point 3.

comment:6 Changed 2 years ago by j.swiderski

  • Status changed from pending to closed
  • Resolution set to invalid

Point 2. This is a bug tracked for reporting bugs. What I've meant is that we have these issues already reported and we will have it fixed in the future. If you can't wait than you can try to write your own custom plugin that handles such cases. These tickets point area on which you should concentrate on or suggest the way in which such plugin can be written. How to write plugins was described here http://docs.cksource.com/CKEditor_3.x/Tutorials

Point 3. If I understand your question correctly, you are asking why Del button works different than Backspace button. Well that is because Del removes what is behind the cursor and Backspace removes what is before the cursor. These are two different keys.
Nevertheless there are browser differences for these buttons. I have reported this bug/browser difference here - #9156


@bsm0206 please note that this is bug tracker for reporting bugs. If you want to ask questions please use contact form in the future- http://cksource.com

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy