Ticket #9133 (closed Bug: wontfix)

Opened 21 months ago

Last modified 18 months ago

IE: Can't apply inline style to empty line.

Reported by: j.swiderski Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: IE Oracle CantFix Cc:

Description

Steps To Recreate:

  1. Open any sample with IE.
  2. Write "1", [Enter], "top", [Enter] 5x, and write "end".
  3. Make a selection from top to end.
  4. Apply a font family, size.
  5. Now click on a blank line in the middle and type and start typing.

RESULT: Your new text will NOT have the font family, size, or bold (or italic or such).

Reproducible from CKEditor 3.0 in all versions of IE's.

Attachments

markup_missing.gif (2.3 KB) - added by j.swiderski 21 months ago.

Change History

Changed 21 months ago by j.swiderski

comment:1 Changed 21 months ago by j.swiderski

  • Status changed from new to confirmed

comment:2 Changed 21 months ago by j.swiderski

This issue may be related to similar reported for Opera - #9134

comment:3 Changed 18 months ago by fredck

  • Status changed from confirmed to closed
  • Keywords CantFix added
  • Resolution set to wontfix

It would be hardly possible to handle this.

Considering that we deal with HTML pages, there is no way for us to clearly maintain a history of interaction on empty lines through HTML elements. The problem is related to collapsed selections (the one that is created when you move into an empty line). Such selections, which is controlled by the browser, will never be created inside empty element eventually present on those lines.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy