Opened 6 years ago

Closed 6 years ago

#10020 closed Bug (duplicate)

CKEditor does not work on XHTML pages !

Reported by: Danil Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: xhtml Cc:

Description

CKEditor is completely not compatible with xhtml (application/xhtml+xml) pages.

CKEditor also is not able to produce xhtml-compliant output due to skipping nbsp; entity.

So, you should not mention XHTML abbreviation everywhere.

Uncaught Error: SYNTAX_ERR: DOM Exception 12 element.js:413
CKEDITOR.tools.extend.setHtml.standard element.js:413
CKEDITOR.dom.element.createFromHtml element.js:74
loadTheme themedui.js:320
(anonymous function) themedui.js:256
listenerFirer event.js:144
CKEDITOR.event.fire event.js:289
CKEDITOR.editor.fire editor_basic.js:24
CKEDITOR.event.fireOnce event.js:332
CKEDITOR.editor.fireOnce editor_basic.js:31
(anonymous function) editor.js:516
doCallback scriptloader.js:70
checkLoaded scriptloader.js:84
onLoad scriptloader.js:98
(anonymous function)

See https://github.com/ajaxorg/ace/ code organization. It works on xhtml pages without any problems.

Change History (1)

comment:1 Changed 6 years ago by Wiktor Walc

Resolution: duplicate
Status: newclosed

Duplicate of #4576

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy