Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#10025 closed Bug (duplicate)

[IE] Selection field dialog permission denied after switching from source

Reported by: Simon Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0.1
Keywords: Cc:

Description

Tested with IE (7 and 9) and the nightly build as of "13-02-03-08-51".

Steps to reproduce.

  1. Add new selection field and some values.
  2. Switch to source and the back to wysiwyg mode.
  3. Press the selection field button to open the dialog.

Result: Script error, permission denied in ckeditor.js (line 42 char 386).

Might be the same cause as in ticket #9177.

Change History (4)

comment:1 Changed 7 years ago by Jakub Ś

Keywords: IE selection field permission denied removed
Resolution: duplicate
Status: newclosed

@nrdmn01 I have added your simplified TC to #9177. I think this is a duplicate of #9177 thus I will close this ticket.

I have one question however - how were you able to reproduce this problem in IE7? I have tried in native IE7 with default settings and nothing happened. Was this by any chance done with IE dev-tools?

comment:2 Changed 7 years ago by Simon

@j.swiderski You are correct, I remembered wrong. The same issue was not reproduced with native IE7.

There was however another issue with IE7 which made me remember wrong. Though this was with CKEditor 3.6.6 and a new ticket could be made (if it not already exists) for that.

The selection field dialog would not close when pressing the OK button whereafter one could not e.g. go into source mode anymore.

comment:3 Changed 7 years ago by Jakub Ś

The selection field dialog would not close when pressing the OK button whereafter one could not e.g. go into source mode anymore.

Probably because of JS error. If you remember TC steps for this ticket yes please report it (if this is a duplicate I will close and link it).

comment:4 Changed 7 years ago by Simon

Since we've updated to v4.x that issue does not concern us anymore as well as that being another issue we can close and link this ticket.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy