Opened 12 years ago

Closed 7 years ago

#1004 closed New Feature (invalid)

Make tables sortable

Reported by: Wiktor Walc Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version:
Keywords: Cc:

Description

Tables in MediaWiki can be sortable using special class:
class="wikitable sortable"
more can be found here:
http://meta.wikimedia.org/wiki/Help:Sorting

Change History (3)

comment:1 Changed 12 years ago by barns

Ideally, the table dialog should have an additional field called "table style" to be able to set the class.
The list of classes would be a select:
1) None

2) Pretty table (=wikitable)

3) Table with sort (=sortable)

4) Pretty table with sort (=wikitable sortable)

The extension notes should indicate that this is customizable in the dialog.
I tried to implement it, but for IE, FCK adds a class to put a border around the table in the editor, and I could not get rid of it.

comment:2 Changed 11 years ago by Wojciech Olchawa

Keywords: Confirmed added

comment:3 Changed 7 years ago by Jakub Ś

Resolution: invalid
Status: confirmedclosed

Since FCKeditor is no longer supported and was replaced with CKEditor, active development of the MediaWiki extension and support for it are also finished.

I’m closing this ticket as it is no longer valid.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy