Opened 7 years ago

Closed 4 years ago

#10070 closed Bug (fixed)

[Android] Selecting and deleting word deletes a single character outside the selection

Reported by: Anna Tomanek Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0
Keywords: Android Cc:

Description (last modified by Anna Tomanek)

Tested on Samsung Galaxy S, Android 4.2.1 (Jelly Bean), CKEditor 4.0.1 samples for the Standard preset, replacebycode and inline sample.

(Beacuse of #9736 it is only possible to select a single word at the same time)

Scenario:

  1. Select a word.
  2. Press the delete key on virtual keyboard.

Expected result: Selected word should be deleted.

Actual result: A single character from outside the selection (one paragraph up) is deleted.

The result does not depend upon input method selected in Android (i.e. selected keyboard).

This problem happens in both iframe and inline mode (though in inline mode not one character is deleted, but a few of them).

In Firefox 18.0.2 the selection is deleted correctly, but the cursor disappears.

Deleting a single character on cursor location works correctly.

Attachments (6)

Android-4.2.1-stock-selection.png (85.3 KB) - added by Anna Tomanek 7 years ago.
Android-4.2.1-stock-deletion.png (162.4 KB) - added by Anna Tomanek 7 years ago.
"r" letter in "first" deleted
Android-4.2.1-stock-inline-selection.png (66.3 KB) - added by Anna Tomanek 7 years ago.
Android-4.2.1-stock-inline-deletion.png (61.9 KB) - added by Anna Tomanek 7 years ago.
"et enim" deleted
Android-4.2.1-firefox-selection.png (85.2 KB) - added by Anna Tomanek 7 years ago.
Android-4.2.1-firefox-deletion.png (80.8 KB) - added by Anna Tomanek 7 years ago.

Download all attachments as: .zip

Change History (12)

Changed 7 years ago by Anna Tomanek

Changed 7 years ago by Anna Tomanek

"r" letter in "first" deleted

Changed 7 years ago by Anna Tomanek

Changed 7 years ago by Anna Tomanek

"et enim" deleted

Changed 7 years ago by Anna Tomanek

Changed 7 years ago by Anna Tomanek

comment:1 Changed 7 years ago by Anna Tomanek

Description: modified (diff)
Status: newconfirmed

comment:2 Changed 7 years ago by Anna Tomanek

Description: modified (diff)

comment:3 Changed 7 years ago by Anna Tomanek

Description: modified (diff)

comment:4 Changed 7 years ago by Anna Tomanek

In Chrome 18.0.1025469 deletion works correctly, but not always, it may take a few tries. For one word it seems to work OK. When the selection is expanded, sometimes the virtual keyboard disappears and one has to redo the selection. It also happens that pressing the Delete button does nothing to the selection and closes the keyboard.

comment:5 Changed 6 years ago by Piotr Jasiun

On Android 4.4.2 with Chrome 33 as default browser this bug does not appears and everything is fine.

comment:6 Changed 4 years ago by Szymon Kupś

Resolution: fixed
Status: confirmedclosed

Tested using CKEditor 4.5.3 on Android 5.1.1 with Chrome 44, stock browser (based on Chrome 39) it worked fine.

Checking on Firefox was not possible because of this #13721. I will close this issue as fixed, but leave a note to test selection deleting in mentioned task.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy