Opened 10 years ago

Closed 5 years ago

#101 closed Bug (wontfix)

IE: Can't use the Styles combo with TR, TD, TH

Reported by: pdvision@… Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.4
Keywords: SF Cc: blasph@…, mjgmaas@…

Description

Hi!
Don't work in IE this style template (fckstyles.xml).

Bug example see on the attachment picture.

...
	<Style name="Table cell class" element="TD">
		<Attribute name="class" value="class_name" />
	</Style>
...

Sorry for my English :)

Attachments (3)

Untitled-1.jpg (36.0 KB) - added by pdvision@… 10 years ago.
CSS style for <TD> tag not visible in toolbar popup panel
td.gif (2.0 KB) - added by Alexander 10 years ago.
the td element does not show up in the dropdown because of the missing <table>
div.gif (1.8 KB) - added by Alexander 10 years ago.
div for example works fine

Download all attachments as: .zip

Change History (16)

Changed 10 years ago by pdvision@…

Attachment: Untitled-1.jpg added

CSS style for <TD> tag not visible in toolbar popup panel

comment:1 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Component: UI : Floating PanelGeneral
Keywords: IE added; CSS removed
Milestone: FCKeditor 2.4
Priority: HighNormal
Summary: In IE CSS style for <TD> tag not visible on toolbar popup panelIE: Can't use the Styles combo with TR, TD, TH

comment:2 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Keywords: SF added

I tried to create the styles on the file fckstyles.xml in the newest version of fckeditor (2.0 rc1) but styles don't been added in style select combo in editor.

If I change to another tag (span, p, etc) it's work fine.


Moved from SF. Original poster: Daniel Rodrigues - blasph
https://sourceforge.net/tracker/index.php?func=detail&aid=1077468&group_id=75348&atid=543653

comment:3 Changed 10 years ago by Alfonso Martínez de Lizarrondo

If you clear your cache in RC3, the style select combo box updates correctly to the changes in fckstyles.xml.

But when I select a cel or a row and want to set the style to one new styles I defined for TD and TR nothing happens.

I added the following styles to fckstyles.xml:

<Style name="tabelKop" element="tr">
      <Attribute name="class" value="tabelKop" />
</Style>
<Style name="tabelCel" element="td">
      <Attribute name="class" value="tabelCel" />
</Style>

In which 'tabelKop' and 'tabelCel' are styles defined in my stylesheet.


Moved from SF. Original poster mjgmaas

comment:4 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Cc: blasph@… mjgmaas@… added

comment:5 Changed 10 years ago by Frederico Caldeira Knabben

The attached screenshot reflects also another problem reported on ticker #126.

comment:6 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 3.0

Part of a fix for it could come on the current dialogs. But I believe that only a tag selector is a definitive solution.

comment:7 Changed 10 years ago by Alexander

I have experienced this Bug too, a really bad thing. The Problem is, that the td Elements get copied in the Style-Dropdown without a wrapping <table>, browsers don't display that.

With block-Level Elements such as div, p, and with inline elements like a, span or b it works fine.

I would suggest to set the priority of this issue to _high_, because of this issue i am not able to use the editor in our system.

Changed 10 years ago by Alexander

Attachment: td.gif added

the td element does not show up in the dropdown because of the missing <table>

Changed 10 years ago by Alexander

Attachment: div.gif added

div for example works fine

comment:8 in reply to:  1 Changed 10 years ago by Alexander

Replying to alfonsoml:

This bug NOT an IE-only bug, I experienced this bug in Firefox as well, and it's most likely that this bug does occur on other browsers as well.

comment:9 Changed 9 years ago by Wojciech Olchawa

Keywords: Confirmed added

comment:10 Changed 9 years ago by Wojciech Olchawa

Keywords: IE removed

comment:11 Changed 8 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.0CKEditor 3.x

comment:12 Changed 7 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.x

Milestone CKEditor 3.x deleted

comment:13 Changed 5 years ago by Jakub Ś

Resolution: wontfix
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible.

Update is recommended thus CKEditor provides styles for objects (from CKEditor 3.6) like table.
There is still one issue with it #9405.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy