Opened 6 years ago

Closed 6 years ago

#10110 closed Bug (invalid)

Extra Line is inserted when Right clicked outside table border

Reported by: KINJAL DAS Owned by:
Priority: Normal Milestone:
Component: General Version: 3.4.2
Keywords: Cc:

Description

I am using CKEditor 3.4.2. I perform the following steps:

1) Add a table with default values. 2) Right click outside of the Table border. 3) The menu item opens and also the table is shifted by one line. In other words, one paragraph is added on top of the table.

Can somebody help me out on this. I tried with other elements, it doesn't happen with CheckBox, form etc.

Any directions will be helpful. I am currently investigating in Flotpanel/Plugin.js as that is called when Menu has to be shown.

P.S. This issue is reproducible in IE, but NOT in FF or chrome.

The issue is not reproducible in demo CkEditor.It is not feasible to upgrade to CkEditor 4, so it will be great if somebody can tell me which files got modified to fix this issue in CkEditor 3.4.2, I might do the changes and see if it fixes the issue.

Change History (2)

comment:1 Changed 6 years ago by KINJAL DAS

comment:2 Changed 6 years ago by Jakub Ś

Keywords: Right Click Table removed
Resolution: invalid
Status: newclosed

can tell me which files got modified to fix this issue in CkEditor 3.4.2

This isn't support site but place to report bugs.

CKEditor 4.x is not 100% backward compatible. Its design was changed to solve most common problems which were impossible to fix in 3.x. The only solution here is upgrading.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy