Opened 7 years ago

Closed 7 years ago

#10133 closed Bug (duplicate)

Deleting heading and hitting delete to pull paragraph into space causes inline styles

Reported by: Joe Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Steps to reproduce:

  1. Use the demo editor: http://ckeditor.com/demo
  2. Click the image and hit delete
  3. Select the heading ("Apollo 11" in the demo)
  4. Hit delete
  5. Hit delete again to pull the following paragraph into the space where the heading was

Source difference between step 3 and 5:

<h1>Apollo 11</h1>

<p><b>Apollo 11</b> was the spaceflight that landed the first humans, Americans <a href="http://en.wikipedia.org/wiki/Neil_Armstrong" title="Neil Armstrong">Neil Armstrong</a> and <a href="http://en.wikipedia.org/wiki/Buzz_Aldrin" title="Buzz Aldrin">Buzz Aldrin</a>, on the Moon on July 20, 1969, at 20:18 UTC. Armstrong became the first to step onto the lunar surface 6 hours later on July 21 at 02:56 UTC.</p>
<h1><b style="font-size: 13px; line-height: 1.6em;">Apollo 11</b><span style="font-size: 13px; line-height: 1.6em;"> was the spaceflight that landed the first humans, Americans </span><a href="http://en.wikipedia.org/wiki/Neil_Armstrong" style="font-size: 13px; line-height: 1.6em;" title="Neil Armstrong">Neil Armstrong</a><span style="font-size: 13px; line-height: 1.6em;"> and </span><a href="http://en.wikipedia.org/wiki/Buzz_Aldrin" style="font-size: 13px; line-height: 1.6em;" title="Buzz Aldrin">Buzz Aldrin</a><span style="font-size: 13px; line-height: 1.6em;">, on the Moon on July 20, 1969, at 20:18 UTC. Armstrong became the first to step onto the lunar surface 6 hours later on July 21 at 02:56 UTC.</span></h1>

Browser/OS Using Chrome 25.0.1364.97 m on windows 7

Also Same effect if you use backspace to pull the paragraph up as opposed to delete to pull it up.

Change History (3)

comment:1 Changed 7 years ago by Joe

Summary: Deleting heading and hitting backspace causes inline styles in following paragraphDeleting heading and hitting delete to pull paragraph into space causes inline styles

comment:2 Changed 7 years ago by Joe

Not sure if deemed a duplicate of http://dev.ckeditor.com/ticket/9998 Definately a similar bug.

comment:3 Changed 7 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed
Version: 4.0.2 (GitHub - master)

@dsmjoe - this is the same issue as #9998

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy