Opened 7 years ago

Closed 7 years ago

#10166 closed Bug (fixed)

Full page sample - image alignment is lost

Reported by: Wiktor Walc Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.1
Component: General Version: 4.1 RC
Keywords: Cc:

Description

align="right"

in the first image at the top is removed

Change History (9)

comment:1 Changed 7 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 7 years ago by Piotrek Koszuliński

This happens because align="right" is not allowed by image plugin. Image plugin uses float rather than align attribute, so this sample is incorrect.

Additionally, transformation group should be added.

Last edited 7 years ago by Piotrek Koszuliński (previous) (diff)

comment:3 Changed 7 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.1

comment:4 Changed 7 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: confirmedassigned

comment:5 Changed 7 years ago by Piotrek Koszuliński

Status: assignedreview

Pushed t/10166 on dev and tests.

comment:6 Changed 7 years ago by Olek Nowodziński

Status: reviewreview_failed

Failing tests:

IE7|8:

  • test-alignleft-attribute-transformation:
    Expected:
    /<p><img data-cke-saved-src="http:\/\/test\/x" src="http:\/\/test\/x" style="float: ?left;?" \/><\/p>/
    Actual:
    <p><img data-cke-saved-src="http://test/x" src="http://test/x" style="FLOAT: left" /></p>
    

FF latest:


Also I guess that this line introduced by this commit can now be reverted.

comment:7 Changed 7 years ago by Piotrek Koszuliński

Status: review_failedreview

I fixed broken tests.

This commit was about switching off ACF in full page sample because in full page usually user need full control over the document.

comment:8 Changed 7 years ago by Olek Nowodziński

Status: reviewreview_passed

comment:9 Changed 7 years ago by Piotrek Koszuliński

Resolution: fixed
Status: review_passedclosed

Fixed on major with git:528fc75 on dev and 247a483 on tests.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy