Opened 7 years ago

Closed 6 years ago

#10183 closed Bug (duplicate)

Error in loading ckeditor on IE9

Reported by: Mehdi Agharlou Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

hi I have error when I want to load a page that have ckeditor init with ie9.

Aspx file: <%@ Page Title="" Language="C#" MasterPageFile="~/GabbehAdmin.Master" AutoEventWireup="true" CodeBehind="About.aspx.cs" Inherits="Gabbeh_Admin.About" %>

<asp:Content ID="headContent" ContentPlaceHolderID="headContentPlaceHolder" runat="server">

<script type="text/javascript" src="ckeditor/ckeditor.js"></script> <script type="text/javascript">

window.onload = function () {

CKEDITOR.replace('editor1');

};

</script>

</asp:Content> <asp:Content ID="Content1" ContentPlaceHolderID="ContentPlaceHolder1" runat="Server">

<h1>

About Us</h1>

<hr /> <br /> <div class="adminEditor">

<textarea name="editor1" rows="" cols="">Test text...</textarea>

</div>

</asp:Content>

Error will happend in ckeditor.js when I run project under ie9.

The error message: Microsoft JScript runtime error: Unable to get value of the property 'textColorTitle': object is null or undefined

and code in ckeditor.js hilighted for error is : ... ,modes:{wysiwyg:1},exec:function(d){if(d. ...

please let me know how can I fix this error.

Change History (2)

comment:1 Changed 7 years ago by Jakub Ś

Status: newpending
Version: 4.0.2

If you are using CKEditor 3.6.4 ASP.NEt with CKEditor 4 JavaScript it is possible that you have downloaded Standard version which doesn't have text color button. There are 3 versions of editor to download Basic, Standard and Full. Each has different number of default plugins.

Go to this page and download full version - http://ckeditor.com/download and it should work.

You can also use builder. Go to this page http://ckeditor.com/builder, select full version (you will see plugins available for it) and if needed select other plugins (Please note that builder contains CKEditor plugins and third party plugins what can be verified on plugin web site)

If this was a reason for your error then please leave a comment so that I could close this ticket.

comment:2 Changed 6 years ago by Wiktor Walc

Resolution: duplicate
Status: pendingclosed

Duplicate of #10335

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy