Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10193 closed Bug (invalid)

TypeError: a.render is not a function

Reported by: Thomas Owned by:
Priority: Normal Milestone:
Component: UI : Toolbar Version: 4.1 RC
Keywords: toolbar, item by item Cc:

Description

Hi ! I just downloaded CKeditor 4.1RC (full package) and get the following error when I try to assign items the custom default toolbar : "TypeError: a.render is not a function".

Here is the simple config file I used to reproduce the bug : I pulled this code from the doc.

/**
 * @license Copyright (c) 2003-2013, CKSource - Frederico Knabben. All rights reserved.
 * For licensing, see LICENSE.html or http://ckeditor.com/license
 */

CKEDITOR.editorConfig = function( config ) {
	// Define changes to default configuration here. For example:
	// config.language = 'fr';
	// config.uiColor = '#AADC6E';
	config.toolbarGroups =
	[
		{ name: 'document', items: [ 'Source', '-', 'NewPage', 'Preview', '-', 'Templates' ] }
	];
};

I hope this is a relevant bug :)

Change History (2)

comment:1 Changed 6 years ago by Piotrek Koszuliński

Resolution: invalid
Status: newclosed

I pulled this code from the doc.

Are you sure? Where have you found that? Because this is not a correct usage of config.toolbarGroups (check docs).

You can set toolbar directly:

config.toolbar = [
	{ name: 'document', items: [ 'Source', '-', 'NewPage', 'Preview', '-', 'Templates' ] }
];

or toolbar groups to for example:

config.toolbarGroups = [
	{ name: 'document',    groups: [ 'mode', 'document', 'doctools' ] },
];

Check the guide http://docs.ckeditor.com/#!/guide/dev_toolbar for more info.

comment:2 Changed 6 years ago by Thomas

Oh lord! Yes it is my fault... In fact, it used to work in 4.0 but now setting toolbarGroups with items doesn't work anymore...

Thank you !

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy