Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10272 closed Task (invalid)

Add functionality - formatting in Editor

Reported by: Carsten Schmitt Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0.2
Keywords: Cc:

Description

Hi there i created 3 new Buttons for me in the Editor. (Information, Error and Warning)

When i klick the Button, the expected Code is written into the Editor. For example, i push "Information" then "%%information mytext%%" is inserted.

When i save everything is how i expected. But when I now go to the editor again. Then the Text "mytext" is unformatted (in the editor) and i don't see, that there is a formatted text.

When I save again everything is fine and right formatted.

So, i only want that the text is also right formatted in the editor. How can i add this?

Hope my question is understandable

Change History (7)

comment:1 Changed 6 years ago by Piotrek Koszuliński

Resolution: invalid
Status: newclosed

comment:2 Changed 6 years ago by Jakub Ś

@Reinmar please see that version is 4.0.2 -> there is no ACF 4.0.2. Issue is still invalid but this could be caused by some server-side processing.


@casi91 Please note that the CKEditor development website is not the right place for support requests.

Please refer to the following article for information on where to get support for all issues related to CKEditor: http://docs.cksource.com/CKEditor_3.x/Howto/Support

Also try using our forums for advice: http://cksource.com/forums/

If you are looking for professional assistance, the CKEditor development team is available via a dedicated support channel that is included in all our commercial licenses: http://ckeditor.com/license


When i save everything is how i expected. But when I now go to the editor again.

This is beyond editor. It has nothing to with how data is kept or processed on server-side. Styles can be attached to HTML elements like span. if this text %%information mytext%% is losing its styles then this may happen because it has no surrounding HTML elements, HTML elements are stripped by some server-side filter etc.

If you think this is bug in editor please provide reduced and working test case file or set of files that allows reproducing this problem. If editor is to blame then such format loss should happen when switching modes - source and back to wysiwyg.

comment:3 in reply to:  2 Changed 6 years ago by Piotrek Koszuliński

Replying to j.swiderski:

@Reinmar please see that version is 4.0.2 -> there is no ACF 4.0.2. Issue is still invalid but this could be caused by some server-side processing.

Hmm... I was so sure that this is ACF that I haven't checked that. Anyway, it doesn't look like an editor issue.

comment:4 Changed 6 years ago by Carsten Schmitt

Sorry for the bad place to post this question.

And it's not an editor issue. I only want to add some functionality (formattings) to the editor, that works in my special case (JSPWiki)

And the formatting isn't lost after i save the document. I only didn't see the formatting when i'm editing again.

So, again sorry for the bad placement. I'll post my next questions in the forum. Thanks

comment:5 Changed 6 years ago by Jakub Ś

@casi91 please track the request (just like before). Please see what is send to JSPWiki and if possible please see where exactly formatting is lost.

NOTE: I don't know how do you format your text but if this is something like <span style="font-size:28px;">%%text</span> the please check if JSPWiki doesn't remove this when e.g. changing %%text to some value.

comment:6 Changed 6 years ago by Carsten Schmitt

I think that my problem is not understandable. I postet the question in the forum with 3 pictures. Maybe then it is unterstandable. http://ckeditor.com/forums/CKEditor/Add-new-formatting-in-Editor

There is no formatting lost. My JSPWiki-Page looks how it should. But while i'm editing the page in the CK editor, the text at this place isnt formatted.

But how i said, please look at the pictures in the forum :-)

comment:7 Changed 6 years ago by Jakub Ś

I have replied to your forum post. I hope everything is clear now.

This ticket will not be continued.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy