Opened 6 years ago

Last modified 6 years ago

#10290 confirmed Bug

Language code with locale handling

Reported by: giammin Owned by:
Priority: Normal Milestone:
Component: General Version: 4.1
Keywords: language Cc:

Description

ckeditor does not handle language code as 'it-IT' or 'en-US', 'en-GB' etc etc

it should fall back to 'it', 'en' or whatever instead it does not recognize these language coeds

Attachments (2)

New folder.zip (374.3 KB) - added by giammin 6 years ago.
to reproduce
10290.html (656 bytes) - added by Piotrek Koszuliński 6 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 6 years ago by giammin

Summary: Language codeLanguage code with locale handling

comment:2 Changed 6 years ago by Piotrek Koszuliński

Resolution: invalid
Status: newclosed

Editor does correctly recognise language based on even if language code is set as 'it-IT', 'en-GB', etc.

E.g. this will work:

CKEDITOR.replace( 'editor1', { language: 'it-IT' } );
// or:
CKEDITOR.replace( 'editor1', { language: 'zh-cn' } );

Do I miss something?

comment:3 Changed 6 years ago by giammin

are you sure?

in my test both normal editor and inline editor do not change ui language if it is set as 'it-IT' but only if it is set as 'it'

comment:4 Changed 6 years ago by Piotrek Koszuliński

  • Which browser have you checked?
  • How do you set language?
  • What's your CKEditor version (number and build - included plugins, languages, etc)?

It would be the best if you could attach a sample (zip package) with your CKEditor package and sample proving the issue.

I'm 100% sure that this setting works on master and latest version of CKEditor (4.1) on Chrome and Firefox.

Changed 6 years ago by giammin

Attachment: New folder.zip added

to reproduce

comment:5 Changed 6 years ago by giammin

tested on chrome: last version

ckeditor version 4.1 last version available from there: http://ckeditor.com/download i have included the ckbuilder config

i think that problem raises when there are more ckeditor instances

thanks!

Last edited 6 years ago by giammin (previous) (diff)

comment:6 Changed 6 years ago by Piotrek Koszuliński

Resolution: invalid
Status: closedreopened

Changed 6 years ago by Piotrek Koszuliński

Attachment: 10290.html added

comment:7 Changed 6 years ago by Piotrek Koszuliński

Status: reopenedconfirmed

Ok. I was able to confirm this issue - you are right that it occurs when there's more than one editor on a page.

comment:8 Changed 6 years ago by Piotrek Koszuliński

Note that the easy fix is to use short language names, without locale.

comment:9 in reply to:  8 Changed 6 years ago by giammin

Replying to Reinmar:

Note that the easy fix is to use short language names, without locale.

Yes, thanks i know about this fix.

comment:10 Changed 6 years ago by giammin

any news/ETA on this?

comment:11 Changed 6 years ago by Piotrek Koszuliński

Nope - none. We're focused on 4.2 right now, but this issue is not considered to be included. It has a simple workaround so it is not a high priority for us now.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy