Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#10292 closed Bug (invalid)

Styles missing from right click menus when in intranet mode in IE8

Reported by: Jennifer Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0.2
Keywords: Cc:

Description

In IE8, when my site is running in Local intranet / protected mode: off, the right click menus don't appear to be styled correctly. In IE, my browser defaults to this mode if the URL doesn't have any . in it, so to reproduce it, you will need to run it on a site like http://ckeditor or http://test . All of the right click menus just appear to be missing their styles. For example, you can compare localintranetmode.png vs internetmode.png.

I could not reproduce this in ckEditor 3.x.

Attachments (4)

localintranetmode.png (52.7 KB) - added by Jennifer 7 years ago.
internetmode.png (50.7 KB) - added by Jennifer 7 years ago.
ckeditor_test.htm (955 bytes) - added by ersan 7 years ago.
ckeditor_test.htm - with X-UA-Compatible tag
right click menu wrong layout.png (39.1 KB) - added by ersan 7 years ago.
Bug in action

Download all attachments as: .zip

Change History (12)

Changed 7 years ago by Jennifer

Attachment: localintranetmode.png added

Changed 7 years ago by Jennifer

Attachment: internetmode.png added

comment:1 Changed 7 years ago by Piotrek Koszuliński

Status: newpending

I'm testing editor from intranet domains on a daily basis. I haven't ever seen an issue caused by that.

I think that you may have some cross domain issue - aren't you trying to load CSS files from other domain? Maybe then IE makes some troubles.

comment:2 Changed 7 years ago by Jennifer

We are only loading our own CSS. No CSS from other domains.

comment:3 Changed 7 years ago by Piotrek Koszuliński

Resolution: invalid
Status: pendingclosed

Without more details we won't be able to reproduce this issue. You may have changed some IE's settings, OS'es settings, editor settings, editor theme's files - all that can cause this problem.

I'm closing this ticket, because I presume that the issue is on your side. However, if you're able to describe a TC which we'll be able to reproduce we can reopen this ticket at any moment.

comment:4 Changed 7 years ago by Jennifer

I am running all the default settings.

In the Local Intranet Zone | Protected Mode: Off, the default Browser Mode is IE8 Compatibility View. You can see this in the IE Developer Tools. With the IE Developer tools, I can change my Browser Mode to IE8 and then the styles appear correctly.

comment:5 Changed 7 years ago by Jakub Ś

I have checked this problem on two local machines in IE9 and IE8 and had no problems with context menus.

  1. Please note that valid way to set compatibility view is using Tools-> Compatibility View Settings -> Display all pages in compatibility view. IE dev tools should not be used for setting this mode but only for checking. Another option you could use is XUA meta tag. Dev tools may give different results thus changing browser or document modes with it, is not valid way to check things.
  2. Protected mode is disabled by default in Intranet.
  3. We have checked that our CSS styles are working fine compatibility view. You were reporting however that your custom css is not working. If we are going to look at this issue could you please provide this CSS and HTML page that is using these styles and editor?
  4. One last thing - please note that in compatibility mode - > document mode is set to IE7. Perhaps menus look broken because you use some CSS rule that is not supported by IE7?

Without CSS and HTML this issue is still invalid.
We are waiting for your feedback.

comment:6 Changed 7 years ago by ersan

Recreated under these conditions

  • CKEditor 4.1.1 Full version (don’t know if this matters) with standard settings, no extra plugins.
  • Installed in /ckeditor directory
  • IE8 with these compatibility view settings:
    • No sites added in the list
    • Only “Show intranet sites in compatibility view” checked
  • HTML-page on web server that IE classify as “Intranet zone” with the attached code (ckeditor_test.htm).

Now request the page with IE. The code uses the meta-tag X-UA-Compatible to set document mode to IE8. If I set this with developer toolbar you don’t get this error.

If you remove the meta-tag no right-click menu is shown at all.

Unchecking “Show intranet sites in compatibility view” is not possible due to a corporate decision. IE8 is widely used within this company so upgrading all users to IE9 or IE10 is not possible.

Thanks!

Changed 7 years ago by ersan

Attachment: ckeditor_test.htm added

ckeditor_test.htm - with X-UA-Compatible tag

Changed 7 years ago by ersan

Bug in action

comment:7 Changed 7 years ago by Jennifer

Can you revisit this considering the additional comment?

comment:8 Changed 7 years ago by Jakub Ś

@jgerth I have checked this issue one more time and with @ersan TC this problem seems to be reproducible. Since there are a lot of unnecessary comments I have opened new issue here: #10427.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy