Opened 6 years ago

Closed 6 years ago

#10320 closed Bug (fixed)

Justify plugin should add elements to ACF based on Enter Mode

Reported by: Jakub Ś Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.1.1
Component: General Version: 4.1
Keywords: Cc:

Description

In full editor use below settings in replacebycode sample.

var editor = CKEDITOR.replace( 'editor1', {
				//allowedContent : true
				enterMode : CKEDITOR.ENTER_BR,
				toolbar : [
				['Font', 'FontSize'], ['TextColor', 'BGColor'], ['Bold', 'Italic', 'Underline', 'Strike'], ['Subscript', 'Superscript'],
				['JustifyLeft', 'JustifyRight', 'JustifyCenter', 'JustifyBlock'], ['NumberedList', 'BulletedList'], ['Outdent', 'Indent', 'Blockquote'], ['Table', 'HorizontalRule', 'SpecialChar'], ['Link', 'Unlink', 'Image'],
				['Cut', 'Copy', 'Paste', 'PasteText', 'PasteFromWord'], ['Undo', 'Redo', '-', 'Find', 'Replace', '-', 'SelectAll', 'RemoveFormat'], ['Source']
				]
			} );

Notice that Justify plugin is disabled no matter what you click on. As discussed with @Rainmar this is because Justify Plugin adds only P to ACF while in other modes (BR and DIV) elements are "wrapped" in DIV when justified (block elements aren't but this rather doesn't change anything). To solve this in other modes, Justify should report DIV to ACF.

Change History (5)

comment:1 Changed 6 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 6 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.1.1
Owner: set to Piotrek Koszuliński
Status: confirmedassigned

comment:3 Changed 6 years ago by Piotrek Koszuliński

Status: assignedreview

Pushed t/10320 on dev and tests.

comment:4 Changed 6 years ago by Olek Nowodziński

Status: reviewreview_passed

comment:5 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: review_passedclosed

Fixed on master with git:5097130 on dev and d48a863 on tests.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy