Opened 6 years ago

Closed 6 years ago

#10323 closed Bug (fixed)

Image window - Not enough room for 4 characters

Reported by: Justine Smithies Owned by:
Priority: Normal Milestone: CKEditor 4.1.1
Component: General Version: 4.0
Keywords: Cc:

Description

When you click on the image button the dialog has two boxes for width and height. They are not wide enough for 4 characters . You need to adjust the size from 40px to say 60px.

Change History (4)

comment:1 Changed 6 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

I have checked this with 4 digits, text like 20px and they fit. In my case only in Chrome and FF last character was "trimmed" a little bit I was able to see it.

I don't see problem here and I don't think we will change this as you cache update dialog with below code:

var editor = CKEDITOR.replace( 'editor1', {});
CKEDITOR.on( 'dialogDefinition', function( ev )	{
				var dialogName = ev.data.name;
				var dialogDefinition = ev.data.definition;						
				
				if ( dialogName == 'image' ){
					var infoTab = dialogDefinition.getContents( 'info' );
					var widthField = infoTab.get( 'txtWidth' );
					var heightField = infoTab.get( 'txtHeight' );
						widthField.width = '60px';				
						heightField.width = '60px';				
				}
			});

comment:2 Changed 6 years ago by Piotrek Koszuliński

Resolution: invalid
Status: closedreopened

I confirm that 4 digits (even starting with narrow "1") does not fit (one of characters is "trimmed a little bit"). I'm reopening this issue since it's trivial to fix and I don't see a point in not fixing this.

comment:3 Changed 6 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.1.1
Status: reopenedconfirmed

comment:4 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed
Version: 4.14.0

Fixed directly on master with git:e6c0d93.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy