Opened 6 years ago

Closed 6 years ago

#10345 closed Bug (fixed)

focus event is not always fired in chrome

Reported by: Jeff Fournier Owned by:
Priority: Normal Milestone:
Component: Core : Focus Version: 4.0
Keywords: Webkit Opera Cc:

Description

If there's no text in the editor and you click, for exemple, in the lower part of the textArea, the focus event will not be fired in chrome. I think it has something to do with the body of the iframe not taking 100%.

I attached the replaceByCode.html sample that I edited to show the bug. The toolbar is collapse at startup and will expand on the focus event and collapse again on the blur event. When there's no text, a lot of time you will click in the editor and the toolbar will not expand.

Attachments (1)

replacebycode.html (2.3 KB) - added by Jeff Fournier 6 years ago.

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by Jeff Fournier

Attachment: replacebycode.html added

comment:1 Changed 6 years ago by Jakub Ś

Keywords: Webkit Opera added
Status: newconfirmed
Version: 4.14.0

Problem can be reproduced in Webkit and Opera from CKEditor 4.0. It works in CKE 3.x branch.

comment:2 Changed 6 years ago by Colum Clissmann

I can reproduce this issue with ckeditor 4.2.2 and Chrome 30.

Is there a plan to fix or should I look at doing something myself?

comment:3 Changed 6 years ago by Colum Clissmann

Actually, I had reproduced with 4.2. With 4.2.2 it is fixed for me.

comment:4 Changed 6 years ago by Jakub Ś

Resolution: fixed
Status: confirmedclosed

works for me too in CKe 4.2.2.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy