Opened 7 years ago

Closed 5 years ago

#10363 closed Bug (fixed)

[Chrome] Unable to remove all contents with SCAYT in some cases

Reported by: Karen Ananiev Owned by:
Priority: Normal Milestone:
Component: UI : Spell Checker Version: 3.0
Keywords: Webkit Cc: WebSpellChecker.net

Description

  1. Enable SCAYT
  2. Create any misspelled header
  3. Create any paragraph and then table or page break
  4. Hit Ctrl+A and wait a few seconds. The selection now is only on header.
  5. Hit Ctrl+A again and then backspace or delete. Only header will be removed.

Change History (4)

comment:1 Changed 7 years ago by Jakub Ś

Cc: WebSpellChecker.net added
Keywords: Webkit added
Status: newconfirmed
Version: 4.13.0

I can confirm this is happening from CKEditor 3.0 in both 3.x and 4.x branches.

To reproduce:

  1. Paste below code in editor
    <h1>dsfdfsdf</h1>
    <table border="1" cellpadding="1" cellspacing="1" style="width:500px">
    	<tbody>
    		<tr>
    			<td>&nbsp;</td>
    			<td>&nbsp;</td>
    		</tr>
    		<tr>
    			<td>&nbsp;</td>
    			<td>&nbsp;</td>
    		</tr>
    		<tr>
    			<td>&nbsp;</td>
    			<td>&nbsp;</td>
    		</tr>
    	</tbody>
    </table>
    <p>&nbsp;</p>
    
  2. Switch to WYSIWYG and enable SCAYT (wait until word gets underlined)
  3. Select all with CTRL+A
  4. Press backspace or delete - Only H1 gets deleted
  5. If you press CTRL+Z and wait few seconds then selection in Chrome and Safari will be removed from table. @karena I was only able to get this effect after initial delete.

This doesn't happen when scayt is disabled.

comment:2 Changed 7 years ago by WebSpellChecker.net

Thank you for provided details. This is known issue in SCAYT Core. Sheduled for review.

comment:3 Changed 6 years ago by Jakub Ś

I wasn't able to reproduce this durring our testing phase.

This could be working because editor is not focused after scayt is enabled. I'm not sure whether not focusing editor after enabling scayt is correct.

comment:4 Changed 5 years ago by Wiktor Walc

Resolution: fixed
Status: confirmedclosed

Unable to reproduce. If anyone can still confirm this issue, please reopen the ticket.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy