Opened 6 years ago

Closed 6 years ago

#10370 closed Bug (fixed)

Inconsistency in data events between framed and inline editors

Reported by: Piotrek Koszuliński Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.2
Component: General Version:
Keywords: Cc:

Description

  1. At the beginning:
  • inline: dataReady, contentDom
  • framed: contentDom, dataReady
  1. After editor.loadSnapshot:
  • inline: loadSnapshot, dataReady
  • framed: loadSnapshot

Change History (7)

comment:1 Changed 6 years ago by Piotrek Koszuliński

Status: newconfirmed

comment:2 Changed 6 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: confirmedassigned

comment:3 Changed 6 years ago by Piotrek Koszuliński

Status: assignedreview

Pushed t/10370 on dev and tests.

I fixed only dataReady on loadSnapshot - it is now fired correctly.

I haven't changed the events order because I would need to complicate the code and this difference seems to be insignificant.

comment:4 Changed 6 years ago by Olek Nowodziński

Rebased branches on major.

comment:5 Changed 6 years ago by Olek Nowodziński

Status: reviewreview_passed

Added doc string for a new method in CKTESTER.tools.

comment:6 Changed 6 years ago by Olek Nowodziński

Extracted the "event order concerns" to #10444.

comment:7 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: review_passedclosed

Fixed on major with git:a4d3172 on dev and d2bc904 on tests.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy