Opened 7 years ago

Closed 6 years ago

#10374 closed Bug (fixed)

Doesn't show tool bar icons if loaded in hidden box

Reported by: Angel Cervera Claudio Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0
Keywords: Firefox Cc: Angel Cervera Claudio

Description

If CKEditor is loaded in a hidden iframe, icons are not showed.

If iframe is inside of hidden div, error persist, so I supposed that the error is when ckeditor is loaded when the parent box is no visible box.

This error is only in new version of Firefox. In Chorme, Shafari and Opera works ok.

Firefox 20.0 Ubuntu 12.10

I attach an example. In this example, I wait 5 second to show iframe because is necessary that ckeditor load when iframe is hidden.

Attachments (3)

error_hidden_box.zip (864 bytes) - added by Angel Cervera Claudio 7 years ago.
example to reproduce error in firefox 20.0
inlinebycode.zip (868 bytes) - added by Jakub Ś 7 years ago.
visibility.zip (831 bytes) - added by Jakub Ś 7 years ago.

Download all attachments as: .zip

Change History (7)

Changed 7 years ago by Angel Cervera Claudio

Attachment: error_hidden_box.zip added

example to reproduce error in firefox 20.0

comment:1 Changed 7 years ago by Jakub Ś

Keywords: Firefox added
Status: newconfirmed
Version: 4.1.1 (GitHub - master)4.0

Problem can be reproduced from CKEditor 4.0 in Firefox only. Furthermore this is only happening when you use display:none and autoinline creation. If you use visibility:hidden or inlinebycode method (please see attached samples) then it works.

I'm confirming this because it is happening only in one browser (just like FF was going in HC mode) but I'm not sure 100% if this ticket is valid - perhaps user should simply use inlinebycode method?

Changed 7 years ago by Jakub Ś

Attachment: inlinebycode.zip added

Changed 7 years ago by Jakub Ś

Attachment: visibility.zip added

comment:2 Changed 7 years ago by Angel Cervera Claudio

I think that must be a low priority bug, because has a workaround. But, in my opinion, is a bug. The question is, why does not work in this version of Firefox? May be a bug in Firefox 20?

comment:3 Changed 7 years ago by Angel Cervera Claudio

Other reason to be a bug is that the workaround, sometimes, is not applicable (or not easily applicable). For example, if user uses jquery to hide content, .hide() method set display:none and not visibility:hidden

Last edited 7 years ago by Angel Cervera Claudio (previous) (diff)

comment:4 Changed 6 years ago by Jakub Ś

Resolution: fixed
Status: confirmedclosed

I have tried reproducing this in latest CKEditor 4.3.1 and Firefox 28 and this issue seems to be working fine now thus I'm closing it as fixed.

@angelcervera are you able to reproduce this issue?

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy