Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10380 closed Bug (invalid)

CKEditor not showing up, Issues in opening CKEditor in tablet\chromebook\iphone

Reported by: vijendra Owned by:
Priority: Normal Milestone:
Component: General Version: 4.2
Keywords: Cc: vijendra.1007@…

Description

Steps:

  1. Open Firefox.
  2. Change the User Agent to iPhone 3.0
  3. Open this URL http://ckeditor.com/demo#standard
  4. Nothing shows up.

Please fix this ASAP. Its a very high priority, showstopper issue, as no- iphone\chromebook user are able to add comment in our website as the comment box is using CKEditor.

Attachments (2)

ScreenHunter_01 Apr. 25 14.23.gif (97.9 KB) - added by vijendra 6 years ago.
Firefox_as_iPhone_demo.png (206.8 KB) - added by Anna Tomanek 6 years ago.

Download all attachments as: .zip

Change History (12)

Changed 6 years ago by vijendra

comment:1 Changed 6 years ago by vijendra

Summary: Showstopper issue - CKEditor not showing uop, Issues in opening CKEditor in tablet\chromebook\iphoneShowstopper issue - CKEditor not showing up, Issues in opening CKEditor in tablet\chromebook\iphone

comment:2 Changed 6 years ago by Anna Tomanek

Summary: Showstopper issue - CKEditor not showing up, Issues in opening CKEditor in tablet\chromebook\iphoneCKEditor not showing up, Issues in opening CKEditor in tablet\chromebook\iphone

comment:3 Changed 6 years ago by Piotrek Koszuliński

Resolution: invalid
Status: newclosed
  1. You cannot change browser agent. CKEditor checks it and if it sees Webkit instead of Firefox, it uses different set of browser's bugfixes. And no, checking browser agent is not a bug - there's no better way in real world.
  1. The support for mobile Safaris is now limited and Android's browser is not supported at all. We're of course accepting issue reports for these browsers, although these have to be issues on real devices.

comment:4 Changed 6 years ago by Anna Tomanek

First of all, CKEditor is an Open Source product. We do not offer custom development and it is quite stunning to see such a demand here; if you check the tone of other ticket reports, yours seems to be quite an exception. You do not own the commercial license nor paid for a premium support level, did you?

Regarding the issue that you submitted. CKEditor is compatible and supported on iOS 6. Your submission does not give any details as to the real OS and browser combinations where it does not work as expected. Instead of that, you pasted a screenshot from Firefox (desktop version) emulating iPhone by using the User Agent Switcher extension -- this is not a reliable test environment. I have just installed the same extension on latest Firefox and the demo works all right.

We appreciate all feedback reports, but please be a bit more mindful before submitting them. Thank you!

Changed 6 years ago by Anna Tomanek

Attachment: Firefox_as_iPhone_demo.png added

comment:5 Changed 6 years ago by vijendra

Anna,

In fact you should be thankful to me for showing the issue. In fact the steps which I showed were the easy way, as I don't have Chromebook\iPhone, to show you REAL demo. Its our customer, who are facing this issue, when they are trying to open the webpage through their Chromebook\iPhone. In fact the way you are talking to me, I didn't liked. Please be careful when talking this way to anyone. If you don't want to fix this, no problem, there are plenty of editors available in the market and we can easily replace the CKditor with other.

THANK YOU.

comment:6 Changed 6 years ago by Piotrek Koszuliński

You should be thankful that someone has worked over 10 years to create CKEditor and definitely should not be so demanding in a first place.

Anyway, this bug report is invalid, since only one reported for real world case makes sense. Please, EOT.

comment:7 Changed 6 years ago by Jakub Ś

@vijendra CKEditor is complex JavaScript application and many times it has to work on the edge. Reproducing something in environment that emulates real environment is not the way to go as they aren't 1:1.

You have told us that CKEditor doesn't work in Chromebook\iPhone but you haven't explained which iPhone. As @Anna has explained support for mobile devices is currently limited but something like opening CKEditor should work. About Chromebook - I don't think we support it. I'm mean it runs some Chrome OS. If this is anything like Linux (and it is based on it) and uses e.g. Chrome it also should work.

About properly reporting tickets - You haven't told us on which version of editor you are getting this issue, on which browser in iPhone and Chromebook. If this is happening in Chrome in Chromebook you could open Chrome webtools and see what the error is (JS or HTTP like 404). Only after gathering some useful information you should report a ticket.

comment:8 in reply to:  5 Changed 6 years ago by Anna Tomanek

Replying to vijendra:

Anna,

In fact you should be thankful to me for showing the issue. In fact the steps which I showed were the easy way, as I don't have Chromebook\iPhone, to show you REAL demo. Its our customer, who are facing this issue, when they are trying to open the webpage through their Chromebook\iPhone. In fact the way you are talking to me, I didn't liked. Please be careful when talking this way to anyone. If you don't want to fix this, no problem, there are plenty of editors available in the market and we can easily replace the CKditor with other.

THANK YOU.

I am really sorry to hear you did not like my answer, though I suggest you read it again and instead of becoming emotional, just try to focus on the issues that I pointed out.

There is nothing that forces you to use CKEditor. We are of course happy if you do, but like I said, you are using an Open Source product, did not pay for it, and are free to move on if you are dissatisfied. I explained to you that we do not offer custom development so your demanding it is simply out of place.

Despite all those facts I did in fact try to be helpful to you, pointed you to our compatibility page and tried out the same Firefox extension that you used to try and reproduce the problem. This issue cannot be reproduced by me, as is visible in the attached screenshot. I asked you to provide a proper list of environments where this issue occured but again, you ignored it and still felt offended that we do not treat your issue properly.

In any case, if you want us to do anything more to investigate this problem you need to tell us where it occurs because we clearly cannot reproduce it even in the same (invalid) test environment that you used.

comment:9 Changed 6 years ago by vijendra

No problem. I too felt I was little harsh with you, so sorry from my end as well.

You see, I don't possess good writing skill :)

Ok, now to repro this issue, the real test scenario I can give you is, I tried opening the ckeditor demo page from my Samsung galaxy R android phone(ice cream sandwitch OS) and it didn't worked there.

Hey, but one thing I can surely tell you is, it was working with older version of CKEditor 3.X (don't exactly remember the version name)

But like you mentioned, it seems to be product limitation. But if we look at the stats, maximum number of user uses Android based smart phone, so I would like if you guys help us and fix the current CKEditor to work perfect with Android based smart phones\tablets.

Thanks, Vijendra

comment:10 Changed 6 years ago by Anna Tomanek

As explained on our compatibility page, Android support is, sadly, not available yet. It's not that we do not want to provide it, the problem is with Google not implementing some vital features of contenteditable support :( Since this is the case, we had to blacklist Android in our env.js file. However, if you want to try it out, you can uncomment the blacklisting code and see for yourself if the level of support that Android browser provides is OK for you, because some features work quite all right already.

You can see the list of open Android bugs by using the Android keyword.

By the way, in some cases CKEditor works quite OK on browsers other than the stock Android browser, i.e. Chrome or Firefox, so you can try these too (after removing the Android blacklisting). And you are most welcome to comment the currently open tickets or open new ones for the issues that you encounter. We do hope to get full Android support eventually.

As for iOS, CKEditor should work on iOS 6 devices. If there are any issues with it, please report the OS, browser version and CKEditor version where it does not work. There are some issues open for iOS too, but nothing critical for the moment.

Thanks for your interest in supporting CKEditor on mobile devices!

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy