Opened 7 years ago

Closed 7 years ago

#10386 closed Bug (invalid)

After Inserting a div it ignores the entermode

Reported by: Ingo Owned by:
Priority: Normal Milestone:
Component: UI : Enter Key Version: 4.1.1
Keywords: Cc:

Description

To Reproduce on the Demo Page http://ckeditor.com/demo#full

  • Switch to Source View
  • Replace the Source Content with <div class="hello">This is a test Text</div>
  • Switch Back to Normal View
  • Insert the cursor after the end of the text Press enter
  • Now it always generates an <div class="hello"></div>

But the default EnterMode is p it should generate the p tags not cloning the div tags

Change History (1)

comment:1 Changed 7 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

The thing is that in that case, the <div> is being used as a paragraph container (because text goes directly on it). Therefore, the editor keeps using the same kind of block until the user doesn't change it back to paragraph (Normal). This is by design.

If you don't like how it works you can use: http://docs.ckeditor.com/#!/api/CKEDITOR.config-cfg-forceEnterMode

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy