Opened 6 years ago

Closed 6 years ago

#10460 closed Bug (invalid)

Inline mode replaces Iframe properties

Reported by: Adam Owned by:
Priority: Normal Milestone:
Component: General Version: 4.1.1
Keywords: Cc:

Description

Prerequisites

  • Full Preset with Source and Iframe plugins

Adding an Iframe element using either the Iframe plugin or Source mode, has all the Iframe properties stripped out while loading data in inline mode.

Steps to reproduce

  1. Load editor in normal edit mode
  2. Click Iframe toolbar button
  3. Enter in "http://www.youtube.com/watch?v=6hWnDTm3oCg" in the URL field, "560" in the Width field, and "316" in the height field and then click OK
  4. Click the Source toolbar button to view the source and verify the code looks like "<iframe frameborder="0" height="315" scrolling="no" src="http://www.youtube.com/watch?v=6hWnDTm3oCg" width="560"></iframe>"
  5. Save data
  6. Refresh page to make sure data displays properly
  7. Switch to Inline editor mode and let saved data load into editor (verified data saved in database is exact data as in step 4)

Expected Result Iframe should load the same in inline edit mode as it does in normal edit mode

Actual Result When launched in inline mode, Iframe loses properties and replaced with div style properties of 100% width and 100% height. Iframe icon is shrunk to 80x80. See attachments

Attachments (4)

normal_edit.PNG (25.9 KB) - added by Adam 6 years ago.
Normal Edit Mode
inline_edit.PNG (97.7 KB) - added by Adam 6 years ago.
Inline edit mode
inline_properties1.PNG (27.2 KB) - added by Adam 6 years ago.
Inline Iframe Properties1
inline_properties2.PNG (24.4 KB) - added by Adam 6 years ago.
Inline Iframe properties2

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by Adam

Attachment: normal_edit.PNG added

Normal Edit Mode

Changed 6 years ago by Adam

Attachment: inline_edit.PNG added

Inline edit mode

Changed 6 years ago by Adam

Attachment: inline_properties1.PNG added

Inline Iframe Properties1

Changed 6 years ago by Adam

Attachment: inline_properties2.PNG added

Inline Iframe properties2

comment:1 Changed 6 years ago by Adam

Resolution: invalid
Status: newclosed

Problem was due to 3rd party script firing on site.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy