Opened 5 years ago

Closed 19 months ago

Last modified 16 months ago

#10472 closed Bug (fixed)

tableresize doesn't work with thead/tfoot

Reported by: Karen Ananiev Owned by: Tade0
Priority: Nice to have (we want to work on it) Milestone: CKEditor 4.7.0
Component: General Version: 3.6
Keywords: Support Cc: rs@…

Description

Unable to resize header/footer table columns.

Change History (12)

comment:1 Changed 5 years ago by Jakub Ś

Status: newconfirmed
Version: 4.1.13.6

It seems plugin has been working that way from very beginning CKE 3.6

You can only see resize cursor when hovering over table cell but not when hovering over header or footers cells.

comment:2 Changed 4 years ago by Kapil

This is a major bug reported by my customers as almost all tables contains header. It is difficult to explain to each user that table cannot be resized from header row.

comment:3 Changed 3 years ago by kemo

Cc: rs@… added

comment:4 Changed 3 years ago by kemo

Same bug on 4.4.7

comment:5 Changed 20 months ago by Jakub Ś

Keywords: Support added

comment:6 Changed 20 months ago by Marek Lewandowski

Priority: NormalNice to have (we want to work on it)

comment:7 Changed 19 months ago by Tade0

Owner: set to Tade0
Status: confirmedreview

Extended the size of the drag handle so that it covers the header and footer.

Changes pushed to branch:t/10472.

Note: no milestone in manual test because no milestone in ticket.

comment:8 Changed 19 months ago by kkrzton

Milestone: CKEditor 4.7.0

comment:9 Changed 19 months ago by kkrzton

Status: reviewreview_failed

Looks and works good!

Pushed only small changes in manual test description and updated version tag (9bfb783).

I only found one strange issue in Firefox - if you move the cursor over the border in the header/footer it does not change to resize cursor. However, if you move it from the border within body (so it already has resize cursor) it stays as a resize cursor when hovering over thead/tfoot border. Also the columns cannot be resized when resize cursor is not visible. Not sure if there is any reasonable fix for this case, but I would like you to take a look on this one.

comment:10 Changed 19 months ago by Tade0

Status: review_failedreview

The fix itself was easy, but it's interesting how it wasn't a problem in other browsers, when it should have been.

Weird.

Anyway, changes pushed to branch:t/10472.

comment:11 Changed 19 months ago by Tomasz Jakut

Resolution: fixed
Status: reviewclosed

LGTM. I've only simplified some getAscendant calls. Fixed with git:ebe3d3e.

comment:12 Changed 16 months ago by Marek Lewandowski

Summary: tableresize doesn't work for thead/tfoottableresize doesn't work with thead/tfoot
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy